Prisma Cloud Compute: Agentless AWS Marketplace Error Seen for Unrelated EC2 Instances

Prisma Cloud Compute: Agentless AWS Marketplace Error Seen for Unrelated EC2 Instances

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Created On 01/20/25 17:33 PM - Last Modified 01/29/25 16:57 PM


Symptom


  • Agentless scan results reflect Marketplace error for one or more unrelated EC2 instances.



Environment


    • Prisma Cloud Compute SaaS version
    • Prisma Cloud Compute Self-hosted version 22.06 and above
    • Agentless scan - Hub Mode
    • AWS


Cause


One or more instances assigned to the same agentless scanner are deployed with an AMI that the hub account is not subscribed to. This error is treated as fatal for the scanner and it does not deploy, resulting in all EC2 instances assigned to that scanner to be skipped and reflect the Marketplace Error (including the instances that are deployed with an AMI the hub account is subscribed to).



Resolution


  • Follow the link included in the error message (when logged into the Hub account) and subscribe to the AMI. 
    • If the AMI is unsupported and/or the user would prefer to skip scanning the VM, they can leverage the Scope by tags option under the Agentless Advanced settings.


Additional Information


Each scanner instance is attached with a maximum of 26* snapshots, which it then scans for security risks. If one EC2 instance is deployed with an AMI that the hub account is not subscribed to, all 26 EC2 instances will reflect a Marketplace error and fail to scan. View our Agentless scanning documentation here.

 



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