Prisma Cloud:ServiceNow Integration 不会根据状态变化重新打开事件

Prisma Cloud:ServiceNow Integration 不会根据状态变化重新打开事件

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Created On 12/31/24 00:24 AM - Last Modified 10/23/25 00:04 AM


Symptom


如果在 ServiceNow 上手动更新事件状态,Prisma Cloud 将不会重新打开事件或更新其状态。



Environment


Prisma 云
*立即服务


Cause


如果用户手动关闭 ServiceNow 上的事件,我们会将该条目保留在数据库中,并向相同的 sysID 发送更新,而不是创建新条目。

当 Prisma Cloud 发送已解决通知时,ServiceNow 将关闭它并向我们发送响应。然后我们将从数据库中删除该条目。因此,下次警报重新打开时,Prisma 将发送创建调用作为通知。



Resolution


选项 1:确保 Prisma 用户在 ServiceNow 中打开的事件不会被手动关闭。手动关闭事件后,我们的数据库中会保留一个条目,后续更新会发送到相同的 sysID,而不是创建新条目。

选项 2:(解决方法)禁用 ServiceNow 通知模板中的“已解决”和“已解除”状态。如果您手动解决 ServiceNow 上的警报,这不会导致任何问题,因为 Prisma 只会将“打开”警报推送到 ServiceNow。



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