Prisma Cloud : l'intégration ServiceNow ne rouvre pas les incidents en fonction d'un changement de état
Symptom
Si le état de l'incident est mis à jour manuellement sur ServiceNow, Prisma Cloud ne rouvrira pas les incidents ni mettre à jour leur état.
Environment
*Nuage prismatique
*ServiceNow
Cause
Si un utilisateur ferme manuellement l’incident sur ServiceNow, nous conservons l’entrée dans notre base de données et envoyons une mettre à jour au même sysID au lieu de créer une nouvelle entrée.
Lorsque Prisma Cloud envoie la notification résolue, ServiceNow la ferme et nous envoie la réponse. Nous supprimons ensuite l'entrée de la base de données. Ainsi, la prochaine fois que l' alerte se rouvre, Prisma enverra l'appel Create sous forme de notification.
Resolution
Option 1 : Assurez-vous que les incidents ouverts par l'utilisateur Prisma dans ServiceNow ne sont pas fermés manuellement. Lorsque les incidents sont fermés manuellement, une entrée reste dans notre base de données et les mises à jour ultérieures sont envoyées au même sysID plutôt que de créer une nouvelle entrée.
Option 2 : (solution de contournement) Désactivez les états « Résolu » et « Ignoré » dans votre modèle de notification ServiceNow. Cela ne posera aucun problème si vous résolvez manuellement les alertes sur ServiceNow, car Prisma enverra uniquement les alertes « Ouvert » à ServiceNow.