Prisma Cloud: ServiceNow Integration öffnet Vorfälle nicht erneut, wenn sich der Status geändert hat
Symptom
Wenn der Status auf ServiceNow manuell aktualisiert wird, öffnet Prisma Cloud die Vorfälle nicht erneut und aktualisieren ihren Status nicht.
Environment
*Prisma Cloud
*ServiceNow
Cause
Wenn ein Benutzer den Vorfall bei ServiceNow manuell schließt, behalten wir den Eintrag in unserer Datenbank und senden ein aktualisieren an dieselbe SysID, anstatt einen neuen Eintrag zu erstellen.
Wenn Prisma Cloud die Benachrichtigung „Behoben“ sendet, schließt ServiceNow sie und sendet uns die Antwort. Wir entfernen dann den Eintrag aus der Datenbank. Wenn der Benachrichtigung das nächste Mal wieder geöffnet wird, sendet Prisma den Anruf „Erstellen“ als Benachrichtigung.
Resolution
Option 1: Stellen Sie sicher, dass vom Prisma-Benutzer in ServiceNow geöffnete Vorfälle nicht manuell geschlossen werden. Wenn Vorfälle manuell geschlossen werden, verbleibt ein Eintrag in unserer Datenbank und nachfolgende Aktualisierungen werden an dieselbe SysID gesendet, anstatt einen neuen Eintrag zu erstellen.
Option 2: (Problemumgehung) Deaktivieren Sie die Status „Gelöst“ und „Abgelehnt“ in Ihrer ServiceNow- Vorlage. Dies würde keine Probleme verursachen, wenn Sie die Warnungen bei ServiceNow manuell auflösen, da Prisma nur „Offene“ Warnungen an ServiceNow sendet.