Prisma Cloud: Missing Assets from the 'Inventory Page' when role is NOT System Admin
Symptom
For any role other than 'System Admin', inventory asset counts may be reduced from onboarded cloud accounts and the “other” category is missing.
Only the System Admin role is capable of seeing all inventory items.
Environment
- Prisma Cloud
- Asset Inventory
Cause
In the Unified Asset Inventory, only System Administrators can view the Compute assets and external assets('Other').
Resolution
This is a day-one behavior, as only the System admin role can view the compute assets. RBAC implementation has not yet been done for non-system admin roles to view compute assets.
Please check this information outlined under the known issues(RLP-68751) section here.
The "other" cloud resources field contains all the assets that are not a part of the CSPM onboarded cloud accounts.
Additional Information
Editing a role's assigned permission group may take up to 15 mins to propagate through the system before reflecting the accurate visibility.