Prisma Cloud Compute : erreur de connectivité GCP sans définition de ressources réseau personnalisées détectée pour l'analyse sans agent
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Created On 10/15/24 16:25 PM - Last Modified 05/01/25 19:12 PM
Symptom
- L'analyse sans agent ne reflète aucun résultat d'analyse pour le projet GCP.
- Un problème de connectivité se reflète dans le projet GCP sous Gérer > Comptes.
- L'erreur suivante apparaît dans les journaux de la console :
(agentless/orchestrator.go:635) agentless scan error for spec: {target="xxxx" hub="" region="xxxx" availabilityDomain=""} target identity: {xxxx } hub identity: { }: all scans were stopped due to connectivity issues target="xxxx" hub="" region="xxxx" availabilityDomain="" job="Scan" workerID="xxxx"Environment
- Version SaaS de Prisma Cloud Compute
- Prisma Cloud Compute version auto-hébergée 22.06 et versions ultérieures
- Analyse sans agent
- BPC
Cause
Ce problème peut être rencontré en raison d'un problème de quota dans le projet GCP.
Resolution
- Vérifiez si une limite de quota est la cause principale en consultant les journaux GCP. Vous devriez voir une entrée comme celle ci-dessous :
{
"protoPayload": {
"@type": "type.googleapis.com/google.cloud.audit.AuditLog",
"status": {
"code": 8,
"message": "QUOTA_EXCEEDED",
"details": [
{
"@type": "type.googleapis.com/google.protobuf.Struct",
"value": {
"quotaExceeded": {
"metric": "SSD_TOTAL_GB",
"limit": 1500,
"resource": {
"resourceType": "DISK",
"resourceName": "prismacloud-scan-xxxx-prisma-agentless-scan-x",
"project": {
"canonicalProjectId": "xxxx"
},
"scope": {
"scopeType": "ZONE",
"scopeName": "xxxx"
}
},
"scope": {
"scopeType": "REGION",
"scopeName": "xxxx"
},
"metricName": "compute.googleapis.com/ssd_total_storage",
"limitName": "SSD-TOTAL-GB-per-project-region"
}
}
}
]
},
"authenticationInfo": {
"principalEmail": "xxxx",
"serviceAccountKeyName": "//iam.googleapis.com/projects/xxxx/serviceAccounts/xxxx/keys/xxxx",
"principalSubject": "serviceAccount:xxxx"
},
"requestMetadata": {
"callerIp": "xxxx",
"callerSuppliedUserAgent": "google-api-go-client/0.5,gzip(gfe)",
"requestAttributes": {},
"destinationAttributes": {}
},
"serviceName": "compute.googleapis.com",
"methodName": "v1.compute.instances.insert",
"resourceName": "projects/xxxx/zones/xxxx/instances/prismacloud-scan-xxxx-prisma-agentless-scan",
"request": {
"@type": "type.googleapis.com/compute.instances.insert"
}
},
"insertId": "xxxx",
"resource": {
"type": "gce_instance",
"labels": {
"project_id": "xxxx",
"zone": "xxxx",
"instance_id": "xxxx"
}
},
"timestamp": "xxxx",
"severity": "ERROR",
"labels": {
"compute.googleapis.com/root_trigger_id": "xxxx"
},
"logName": "projects/xxxx/logs/cloudaudit.googleapis.com%2Factivity",
"operation": {
"id": "xxxx",
"producer": "compute.googleapis.com",
"last": true
},
"receiveTimestamp": "xxxx"
}
- Le journal GCP doit indiquer quel quota doit être augmenté.
- Augmentez la valeur du quota applicable selon les besoins dans GCP sous « Quotas et limites du système ».
Additional Information
Si des ressources réseau personnalisées sont définies, vérifiez que le scanner est en mesure de communiquer avec la console Prisma Cloud. S'il s'agit d'un déploiement SaaS , reportez-vous à la documentation relative aux prérequis de la console Prisma Cloud pour connaître les adresses IP de passerelle NAT requises.