Prisma Cloud Compute: Beim ohne Agent Scan wurde ein GCP-Konnektivitätsfehler ohne Definition benutzerdefinierter Netzwerkressourcen festgestellt
2126
Created On 10/15/24 16:25 PM - Last Modified 05/01/25 19:12 PM
Symptom
- Der ohne Agent Scan spiegelt keine Scanergebnisse für das GCP-Projekt wider.
- Ein Konnektivitätsproblem wird für das GCP-Projekt unter „Verwalten > Konten“ angezeigt.
- In den Konsolenprotokollen wird folgender Fehler angezeigt:
(agentless/orchestrator.go:635) agentless scan error for spec: {target="xxxx" hub="" region="xxxx" availabilityDomain=""} target identity: {xxxx } hub identity: { }: all scans were stopped due to connectivity issues target="xxxx" hub="" region="xxxx" availabilityDomain="" job="Scan" workerID="xxxx"Environment
- Prisma Cloud Compute SaaS Version
- Prisma Cloud Compute Selbstgehostete Version 22.06 und höher
- ohne Agent Scan
- GCP
Cause
Dieses Problem kann aufgrund eines Kontingentproblems im GCP-Projekt auftreten.
Resolution
- Überprüfen Sie anhand der GCP-Protokolle, ob ein Kontingentlimit die Grundursache ist. Sie sollten einen Eintrag wie den folgenden sehen:
{
"protoPayload": {
"@type": "type.googleapis.com/google.cloud.audit.AuditLog",
"status": {
"code": 8,
"message": "QUOTA_EXCEEDED",
"details": [
{
"@type": "type.googleapis.com/google.protobuf.Struct",
"value": {
"quotaExceeded": {
"metric": "SSD_TOTAL_GB",
"limit": 1500,
"resource": {
"resourceType": "DISK",
"resourceName": "prismacloud-scan-xxxx-prisma-agentless-scan-x",
"project": {
"canonicalProjectId": "xxxx"
},
"scope": {
"scopeType": "ZONE",
"scopeName": "xxxx"
}
},
"scope": {
"scopeType": "REGION",
"scopeName": "xxxx"
},
"metricName": "compute.googleapis.com/ssd_total_storage",
"limitName": "SSD-TOTAL-GB-per-project-region"
}
}
}
]
},
"authenticationInfo": {
"principalEmail": "xxxx",
"serviceAccountKeyName": "//iam.googleapis.com/projects/xxxx/serviceAccounts/xxxx/keys/xxxx",
"principalSubject": "serviceAccount:xxxx"
},
"requestMetadata": {
"callerIp": "xxxx",
"callerSuppliedUserAgent": "google-api-go-client/0.5,gzip(gfe)",
"requestAttributes": {},
"destinationAttributes": {}
},
"serviceName": "compute.googleapis.com",
"methodName": "v1.compute.instances.insert",
"resourceName": "projects/xxxx/zones/xxxx/instances/prismacloud-scan-xxxx-prisma-agentless-scan",
"request": {
"@type": "type.googleapis.com/compute.instances.insert"
}
},
"insertId": "xxxx",
"resource": {
"type": "gce_instance",
"labels": {
"project_id": "xxxx",
"zone": "xxxx",
"instance_id": "xxxx"
}
},
"timestamp": "xxxx",
"severity": "ERROR",
"labels": {
"compute.googleapis.com/root_trigger_id": "xxxx"
},
"logName": "projects/xxxx/logs/cloudaudit.googleapis.com%2Factivity",
"operation": {
"id": "xxxx",
"producer": "compute.googleapis.com",
"last": true
},
"receiveTimestamp": "xxxx"
}
- Das GCP-Protokoll sollte angeben, welches Kontingent erhöht werden muss.
- Erhöhen Sie bei Bedarf den geltenden Kontingentwert innerhalb von GCP unter „Kontingente und Systemlimits“.
Additional Information
Wenn benutzerdefinierte Netzwerkressourcen definiert sind, überprüfen Sie, ob der Scanner mit der Prisma Cloud Console kommunizieren kann. Wenn es sich um eine SaaS Bereitstellung handelt, finden Sie die erforderlichen NAT Gateway-IP-Adressen in der Dokumentation zu den Voraussetzungen für die Prisma Cloud Console .