Flow Control (FC) and app-engine process restarts on the ION device
619
Created On 09/12/24 12:38 PM - Last Modified 04/09/26 02:32 AM
Symptom
- ION device reboots without manual intervention.
- The SCM Incident section indicates crashes within the FC or app-engine processes.
- A spike in new flows is visible in the SCM "Activity" tab, coinciding with the timing of the process crashes.
Environment
- Prisma SD-WAN
- ION devices
- 6.1.x software version
- Strata Cloud Manager (SCM)
Cause
- A sudden surge in the volume of new traffic flows can overwhelm the system, leading to a device crash.
- The high demand placed on resources by network scanning applications can also trigger these crashes.
Resolution
In environments where network scanning is utilized, Implement the following configuration to maintain stability:
- Identify the specific IP addresses of all network scan servers.
- Create custom-app with the following settings
- Unreachability Detection: Disabled
- Path Affinity: None
- Network Scan App: Enabled
Additional Information
The following commands help to diagnose the issue and must be collected during the issue:
inspect user-app-session all
inspect flow brief srcv4=<scan-server>
dump app-engine memory-stats (to be collected during session spike)
dump app-engine app-stats uappname=enterprise-unknown (to be collected during session spike)