Des résultats incohérents sont observés pour le « groupe de ressources Azure » dans Prisma Cloud
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Created On 08/15/24 03:51 AM - Last Modified 10/02/24 23:56 PM
Symptom
- Azure Resource Group est un composant Azure dans lequel Azure crée des ressources
- Les groupes de ressources Azure sont activés au niveau du locataire
- Résultats incohérents pour le « groupe de ressources Azure »
- Par exemple, lorsqu’il est observé chez :
- Comme indiqué ci-dessous, l'inventaire (ressources) et l'examen (RQL) indiquent le nombre de « groupes de ressources Azure » = 1637 dans un environnement particulier
Alertes et conformité = 1493
- Comme indiqué ci-dessous, Alertes et conformité affiche le nombre de « groupes de ressources Azure » = 1493 dans un environnement particulier
Liste des ressources = 1368
- Comme indiqué ci-dessous, la liste des ressources indique le nombre de « groupes de ressources Azure » = 1368 dans un environnement particulier
Environment
- Prisma Cloud
- Microsoft Azure
Cause
Inventaire (actifs) et enquête (RQL)
- Liste d’inventaire (actifs) et d’investigation (RQL)
- Actifs actifs actuels
- Comprend des entrées en double
- Liste des alertes et de la conformité
- Actifs actifs actuels
- Ressources supprimées
- Entrées uniques
- Listes de ressources
- Actifs actifs actuels
- Entrées uniques
- Dans l’exemple ci-dessus, plusieurs entrées de ressources pour PCCAgentlessScanResourceGroup sont visibles dans l’onglet Inventaire et Examiner (Nombre = 7)
- Bien qu’ils portent le même nom, il s’agit d’actifs totalement différents situés dans différentes régions de compte cloud
Enquêter
- Cependant, sous l’onglet Alertes, conformité et liste des ressources, vous ne trouverez qu’une seule entrée unique pour le même
de conformité
des alertes
- En outre, vous pouvez exécuter une requête RQL spécifique pour trouver les ressources « Groupe de ressources Azure » supprimées (le nombre est de 144)
Resolution
- Il s’agit d’un comportement attendu selon la conception du produit
Additional Information
- Les alertes associées aux comptes Cloud actifs sont actuellement conservées pendant toute la durée du service
- Lorsque des comptes Cloud sont supprimés de Prisma Cloud, les alertes associées sont conservées pendant 24 heures supplémentaires, après quoi elles sont définitivement supprimées
- La configuration des ressources actives dans l’environnement cloud est conservée pendant toute la durée du service
- À la fin du service, les données des systèmes en direct sont stockées pendant une période maximale de 60 jours, après quoi elles seront supprimées des systèmes en direct
- La purge des données de sauvegarde peut prendre jusqu’à 60 jours supplémentaires