Resultados incoherentes observados para "Azure Resource Group" en Prisma Cloud
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Created On 08/15/24 03:51 AM - Last Modified 10/02/24 23:56 PM
Symptom
- El grupo de recursos de Azure es un componente de Azure en el que Azure crea recursos
- Los grupos de recursos de Azure están habilitados en el nivel de inquilino
- Resultados incoherentes vistos para "Grupo de recursos de Azure"
- Por ejemplo, cuando se observa en:
- Como se muestra a continuación, Inventario (Activos) e Investigación (RQL) muestran el recuento de "Grupo de recursos de Azure" = 1637 en un entorno determinado
Alertas y cumplimiento = 1493
- Como se muestra a continuación, Alertas y cumplimiento muestra el recuento del "grupo de recursos de Azure" = 1493 en un entorno determinado
Lista de recursos = 1368
- Como se muestra a continuación, la lista de recursos muestra el recuento del "grupo de recursos de Azure" = 1368 en un entorno determinado
Environment
- Prisma Cloud
- Microsoft Azure
Cause
Inventario (activos) e investigación (RQL)
- Lista de inventario (activos) e investigación (RQL)
- Activos Activos Actuales
- Incluye entradas duplicadas
- Lista de alertas y cumplimiento
- Activos Activos Actuales
- Recursos eliminados
- Entradas únicas
- Listas de listas de recursos
- Activos Activos Actuales
- Entradas únicas
- En el ejemplo anterior, las entradas de recursos múltiples para PCCAgentlessScanResourceGroup se ven en la pestaña Inventario e investigación (Recuento = 7)
- Aunque tienen el mismo nombre, son activos completamente diferentes ubicados en diferentes regiones de cuentas en la nube
- Sin embargo, en la pestaña Alertas, cumplimiento y lista de recursos, solo encontrará 1 entrada única para el mismo
Lista de
recursos
de cumplimiento
de alertas
- Además, puede ejecutar una consulta RQL específica para buscar los recursos "Grupo de recursos de Azure" eliminados (el recuento es 144)
Resolution
- Este es el comportamiento esperado según el diseño del producto
Additional Information
- Las alertas asociadas con las cuentas activas de Cloud se conservan actualmente mientras dure el servicio
- Cuando las cuentas en la nube se eliminan de Prisma Cloud, las alertas asociadas se mantienen durante 24 horas adicionales, después de lo cual se eliminan permanentemente
- La configuración de los activos activos en el entorno de nube también se conserva durante la duración del servicio
- Tras la terminación del servicio, los datos en los sistemas en vivo se almacenan hasta por 60 días, después de lo cual se eliminarán de los sistemas en vivo
- La purga de los datos de copia de seguridad puede tardar hasta 60 días adicionales