Inkonsistente Ergebnisse für "Azure-Ressourcengruppe" in Prisma Cloud
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Created On 08/15/24 03:51 AM - Last Modified 10/02/24 23:56 PM
Symptom
- Die Azure-Ressourcengruppe ist eine Azure-Komponente, in der Azure Ressourcen erstellt
- Azure-Ressourcengruppen sind auf Mandantenebene aktiviert
- Inkonsistente Ergebnisse für "Azure-Ressourcengruppe"
- Zum Beispiel, wenn es beobachtet wird in:
- Wie unten gezeigt, zeigt Inventory (Assets) und Investigate (RQL) die Anzahl der Azure-Ressourcengruppen = 1637 in einer bestimmten Umgebung an
Warnungen und Compliance = 1493
- Wie unten gezeigt, zeigt "Warnungen und Kompatibilität" die Anzahl der Azure-Ressourcengruppen = 1493 in einer bestimmten Umgebung an
Ressourcenliste = 1368
- Wie unten gezeigt, zeigt die Ressourcenliste die Anzahl der Azure-Ressourcengruppen = 1368 in einer bestimmten Umgebung an
Environment
- Prisma Cloud
- Microsoft Azure
Cause
Inventarisierung (Assets) und Untersuchung (RQL)
- Liste "Inventarisierung (Assets)" und "Untersuchen" (RQL)
- Kurzfristig Aktive Vermögenswerte
- Beinhaltet doppelte Einträge
- Liste "Warnungen und Compliance"
- Kurzfristig Aktive Vermögenswerte
- Gelöschte Assets
- Einmalige Einträge
- Listen der Ressourcenliste
- Kurzfristig Aktive Vermögenswerte
- Einmalige Einträge
- Im obigen Beispiel werden mehrere Ressourceneinträge für PCCAgentlessScanResourceGroup auf der Registerkarte "Bestand und Untersuchung" angezeigt (Anzahl = 7)
- Obwohl sie denselben Namen haben, handelt es sich um völlig unterschiedliche Assets, die sich in verschiedenen Cloud-Kontoregionen befinden
untersuchen
- Auf der Registerkarte "Warnungen", "Compliance" und "Ressourcenliste" finden Sie jedoch nur 1 eindeutigen Eintrag für denselben Eintrag
für die Einhaltung
von Warnungen
- Darüber hinaus können Sie eine bestimmte RQL-Abfrage ausführen, um die gelöschten "Azure-Ressourcengruppen"-Ressourcen zu finden (die Anzahl beträgt 144)
Resolution
- Dies ist das erwartete Verhalten gemäß dem Produktdesign
Additional Information
- Warnungen, die mit aktiven Cloud-Konten verknüpft sind, werden derzeit für die Dauer des Dienstes aufbewahrt
- Wenn Cloud-Konten aus Prisma Cloud gelöscht werden, werden die zugehörigen Warnungen für weitere 24 Stunden aufbewahrt und danach dauerhaft gelöscht
- Die Konfiguration von Assets, die in der Cloud-Umgebung aktiv sind, wird auch für die Dauer des Dienstes beibehalten
- Nach Beendigung des Dienstes werden die Daten in Live-Systemen bis zu 60 Tage lang gespeichert, danach werden sie aus den Live-Systemen gelöscht
- Das Löschen von Sicherungsdaten kann bis zu 60 weitere Tage dauern