GlobalProtect App crashes repeatedly when outdated WebView2 Runtime is used on the client

GlobalProtect App crashes repeatedly when outdated WebView2 Runtime is used on the client

1135
Created On 03/03/25 08:25 AM - Last Modified 08/08/25 20:53 PM


Symptom


  • PanGPA process restarts repeatedly.
  • GlobalProtect is unable to connect to a gateway.
  • The SAML authentication window is not displayed.
  • The WebView2 Runtime version is very old (e.g. 100.0.1185.36).

PanGPA.log:

(P9064-T7176)Info   ( 684): 02/25/25 16:21:48:303 ####################### Start PanGPA #######################
(P15824-T16000)Info ( 684): 02/25/25 16:21:58:599 ####################### Start PanGPA #######################
(P10712-T16284)Info ( 684): 02/25/25 16:22:08:203 ####################### Start PanGPA #######################
(P3496-T3904)Info ( 684): 02/25/25 16:22:17:879 ####################### Start PanGPA #######################
(P8812-T8864)Info ( 684): 02/25/25 16:22:27:304 ####################### Start PanGPA #######################
(P1440-T2004)Info ( 684): 02/25/25 16:22:36:701 ####################### Start PanGPA #######################
(P3808-T11584)Info ( 684): 02/25/25 16:22:46:126 ####################### Start PanGPA #######################
(P12772-T11504)Info ( 684): 02/25/25 16:22:56:415 ####################### Start PanGPA #######################

PanGPS.log:

(P6760-T9304)Debug(10552): 02/25/25 16:22:29:556 ----Portal Login starts----
.....(Output Omitted).....
(P6760-T9304)Debug(2387): 02/25/25 16:22:29:557 Send response to client for request saml-pre-login

(P6760-T8620)Debug( 144): 02/25/25 16:22:31:620 CheckPanGpAgentThread: PanGPA process 8812 exits, ret is 00000057.
(P6760-T8620)Debug( 152): 02/25/25 16:22:31:620 GlobalProtect agent terminates unexpectedly. Skip StopThreads().


Environment




Cause


  • PanGPA.log shows that the WebView2 Runtime version is running on 100.0.1185.36, which is out of date and no longer supported by Microsoft leading to process crash.
(P3496-T3904)Debug(1092): 02/25/25 16:22:20:157 CPanSAMLView:: Install Path c:\Program Files (x86)\Microsoft\EdgeWebView\Application\100.0.1185.36
(P3496-T3904)Debug(1232): 02/25/25 16:22:20:157 WebView2 GetUserDataFolder: C:\Users\kpcadm16\AppData\Local\Palo Alto Networks\GlobalProtect\GPAEdge\SamlViewEdge100.0.1185.36
(P3496-T3904)Debug( 217): 02/25/25 16:22:20:157 PanSAMLView subFolder: c:\Program Files (x86)\Microsoft\EdgeWebView\Application\100.0.1185.36
appData: C:\Users\kpcadm16\AppData\Local\Palo Alto Networks\GlobalProtect\GPAEdge\SamlViewEdge100.0.1185.36


Resolution


  1. Upgrade the WebView2 Runtime to the latest version
  2. Then reinstall the GlobalProtect App.


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