Prisma Cloud Compute: Scan is failing with error "413 : Request Entity Too Large”
781
Created On 01/15/25 19:26 PM - Last Modified 05/01/25 20:55 PM
Symptom
CI/CD twistcli scan failure, see error below.
Environment
- Prisma Cloud Runtime Security
- Prisma Cloud Compute Edition
Cause
NGNIX proxy misconfiguration causes this issue.
- By default, HTTP client_max_body_size in the NGINX proxy is set to 1 MB, which makes it impossible for the NGINX server to handle a large payload of scan results.
- As per the NGINX proxy documentation here, If the size in a request exceeds the configured value, the 413 (Request Entity Too Large) error is returned to the client.
Resolution
- Increase HTTP client_max_body_size in NGINX proxy to 100Mb minimum.
- Setting
sizeto 0 disables checking of client request body size and this can resolve this error and help twistcli to upload scan results to Prisma Runtime/Compute Console.
Additional Information
Nginx Documentation Link here