DNS Security does not work after configuration

DNS Security does not work after configuration

4087
Created On 11/11/24 16:00 PM - Last Modified 12/01/24 13:10 PM


Symptom


  • The DNS traffic is passing through a security policy with Anti-spyware configured.
  • Anti-spyware DNS security is configured with an action block for malicious domains ( phishing, malware, C2, .. etc )
  • when doing nslookup for a malicious site from the client machine to the DNS resolver, the query passes through without detection where it should
  • Checking the global counters, no increase in ctd_dns counters. 
  • Noticing only the below counters: 
    
    > show counter global | match ctd_dns
    
    ctd_dns_id_update           3 0  info ctd pktproc Number of DNS id update from MP
    ctd_dns_response_error 694894 0 error ctd pktproc Number of Error DNS response from MP


Environment


  • Palo Alto Firewalls
  • PAN-OS 10.1
  • DNS Security


Cause


The config from the GUI for the antispyware profile is not applied. The running config does not reflect the configured profile.



Resolution


  1. Make a simple change related to the DNS security config on the Anti-Spyware profile.
  2. Commit the config.
  3. Revert the modified change (The change is just done to populate the DNS security config on the running config)
  4. Commit the changes again.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000HES5CAO&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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