GlobalProtect Single Sign-Out (SLO) funktioniert zeitweise nicht
Symptom
GlobalProtects Single Sign-Out (SLO) funktioniert manchmal und manchmal nicht.
Environment
- GlobalProtect
- Prisma Access Mobile-Benutzer
- SAML-Authentifizierung
Cause
Das GPGW erstellt kein SLO, wenn die Gateway-Authentifizierung mit einem Cookie erfolgt. Dies ist das erwartete Verhalten. Da das GPGW die SAML- anfordern/Anforderung/ Antwort beim Anmeldung nicht verarbeitet, gibt es keine Informationen zum Ausführen von SLO.
Wenn Sie das GlobalProtect-Protokoll mit „(stage eq ‚connected‘)“ oder „(stage eq ‚logout‘)“ filtern , wird angezeigt, wenn der Benutzer mit SAML oder Cookie eine Verbindung zu GPGW herstellt.
Resolution
Wenn das SLO die absolute Anforderung des Kunden ist, deaktivieren Sie die außer Kraft setzen/Außerkraftsetzung des Authentifizierungscookies. Dies führt dazu, dass GlobalProtect-Benutzer einer SAML-Authentifizierung unterzogen werden, die bei jeder Verbindung mit GlobalProtect zweimal für das Portal und das Gateway durchgeführt wird.