Épuisement de la mémoire de processus - Distribué
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Created On 09/18/24 17:21 PM - Last Modified 07/11/25 15:55 PM
Symptom
- Alerte concernant l’épuisement de la mémoire de processus pour « distributeur »
Environment
- Pan-OS
Cause
Un épuisement de la mémoire dans le processus « distribué » a été trouvé.
Resolution
- Rassemblez les données suivantes nécessaires pour diagnostiquer la cause de l’épuisement de la mémoire distribuée :
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Collectez le fichier de support technique à partir de l’interface utilisateur : Support > périphérique > Générer un fichier de support technique.
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Exécutez les commandes CLI suivantes pour collecter les fichiers de trace et de base :
show clock debug software trace distributord debug software core distributord
Téléchargez les fichiers principaux à partir de l’interface utilisateur : Prise en charge > l’appareil > Télécharger les fichiers principaux. Pour le vidage de trace, copiez la sortie CLI, collez-la dans un fichier bloc-notes et enregistrez-la.
- Exportez l’état de l’appareil à partir de l’interface utilisateur : Configuration > opérations > l’appareil > Exporter l’état de l’appareil.
- Recueillez des données à partir de Strata Cloud Manager, telles que la date de début de l’épuisement de la mémoire et toute modification de configuration ou de logiciel effectuée pendant cette période.
- Ouvrez un dossier d’assistance avec les données ci-dessus.
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- Utilisez les étapes d’atténuation suivantes comme correctif temporaire :
- Redémarrez le processus distribué pour réduire l’utilisation de la mémoire à l’aide de la commande :
debug software restart process distributord
Remarque :
- Cette action est recommandée lors d’une fenêtre de maintenance.
- Le redémarrage
de Distributordatténue temporairement la croissance de la mémoire, mais le problème peut se reproduire.
- Redémarrez le processus distribué pour réduire l’utilisation de la mémoire à l’aide de la commande :
Additional Information
PAN-224354 : Correction d’un problème où une fuite de mémoire liée au processus distribué se produisait lorsque les connexions se battaient pour la redistribution du mappage de l’adresse IP au nom d’utilisateur. (Corrigé dans les versions 10.2.8, 10.1.12, 11.0.4 ou 11.1.0 ou ultérieure).
Si le pare-feu ou Panorama est affecté par le problème logiciel PAN-224354, effectuez une mise à niveau vers une version avec le correctif ou une version ultérieure.