Agotamiento de la memoria de proceso - Distribuido
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Created On 09/18/24 17:21 PM - Last Modified 07/11/25 15:55 PM
Symptom
- Alerta sobre el agotamiento de la memoria de proceso para "distribuido"
Environment
- PAN-os
Cause
Se encontró un agotamiento de la memoria en el proceso "distribuido".
Resolution
- Recopile los siguientes datos necesarios para diagnosticar la causa del agotamiento de la memoria distribuida:
-
Recopilar archivo de soporte técnico de la interfaz de usuario: Soporte > dispositivo > Generar archivo de soporte técnico.
-
Ejecute los siguientes comandos de la CLI para recopilar archivos de seguimiento y principales:
show clock debug software trace distributord debug software core distributord
Descargue los archivos principales de la interfaz de usuario: Compatibilidad con dispositivos > > Descargar archivos principales. Para el volcado de seguimiento, copie la salida de la CLI, péguela en un archivo de bloc de notas y guárdela.
- Exporte el estado del dispositivo desde la interfaz de usuario: Configuración del dispositivo > > operaciones > Exportar estado del dispositivo.
- Recopile datos de Strata Cloud Manager, como la fecha de inicio del agotamiento de la memoria y cualquier cambio de configuración o software realizado durante ese tiempo.
- Abra un caso de soporte con los datos anteriores.
-
- Use los siguientes pasos de mitigación como solución temporal:
- Reinicie el proceso distribuido para reducir el uso de memoria mediante el comando:
debug software restart process distributord
Nota:
- Esta acción se recomienda durante un período de mantenimiento.
- El reinicio
de distributedmitiga temporalmente el crecimiento de la memoria, pero el problema puede volver a ocurrir.
- Reinicie el proceso distribuido para reducir el uso de memoria mediante el comando:
Additional Information
PAN-224354: Se ha corregido un problema por el que se producía una pérdida de memoria relacionada con el proceso distribuido cuando las conexiones se movían para la redistribución de la asignación de dirección IP a nombre de usuario. (Solucionado en 10.2.8, 10.1.12, 11.0.4 o 11.1.0 o versiones posteriores).
Si el firewall o Panorama se ven afectados por el problema de software PAN-224354, actualice a una versión con la corrección o a una versión posterior.