Erschöpfung des Prozessspeichers - Verteiler

Erschöpfung des Prozessspeichers - Verteiler

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Created On 09/18/24 17:21 PM - Last Modified 07/11/25 15:55 PM


Symptom


  • Warnung bezüglich Erschöpfung des Prozessspeichers für "distributord"


Environment


  • Pan-OS


Cause


Es wurde eine Speichererschöpfung im "distributed"-Prozess festgestellt.

Resolution


  1. Sammeln Sie die folgenden Daten, die zum Diagnostizieren der Ursache der verteilergebundenen Speichererschöpfung erforderlich sind:
    1. Erfassen Sie die Tech-Support-Datei über die Benutzeroberfläche: Device > Support > Generate Tech Support-Datei.

    2. Führen Sie die folgenden CLI-Befehle aus, um Ablaufverfolgungs- und Kerndateien zu sammeln:

      show clock
      debug software trace distributord
      debug software core distributord

      Laden Sie die Kerndateien von der Benutzeroberfläche herunter: Geräte- > > Kerndateien herunterladen. Kopieren Sie für das Ablaufverfolgungsabbild die CLI-Ausgabe, fügen Sie sie in eine Editor-Datei ein, und speichern Sie sie.

    3. Exportieren Sie den Gerätestatus über die Benutzeroberfläche: Gerät > Setup- > Vorgänge > Gerätestatus exportieren.
    4. Erfassen Sie Daten von Strata Cloud Manager, wie z. B. das Startdatum der Speichererschöpfung und alle Konfigurations- oder Softwareänderungen, die während dieser Zeit vorgenommen wurden.
    5. Öffnen Sie einen Supportfall mit den oben genannten Daten.
  2. Verwenden Sie die folgenden Schritte zur Risikominderung als vorübergehende Lösung:
    1. Starten Sie den distributed-Prozess neu, um die Speicherauslastung zu reduzieren, indem Sie den folgenden Befehl verwenden:
      debug software restart process distributord
      Hinweis:
    • Diese Aktion wird während eines Wartungsfensters empfohlen.
    • Durch einen Neustart von distributord wird das Speicherwachstum vorübergehend verringert, das Problem kann jedoch erneut auftreten.


Additional Information


PAN-224354: Es wurde ein Problem behoben, bei dem ein Speicherleck im Zusammenhang mit dem distributed-Prozess auftrat, wenn Verbindungen für die Neuverteilung der IP-Adress-zu-Benutzername-Zuordnung durchschlugen. (Behoben in Version 10.2.8, 10.1.12, 11.0.4 oder 11.1.0 oder höher).
Wenn die Firewall oder Panorama von dem Softwareproblem PAN-224354 betroffen ist, führen Sie ein Upgrade auf eine Version mit dem Fix oder eine höhere Version durch.


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