Épuisement de la mémoire de processus - Snmpd

Épuisement de la mémoire de processus - Snmpd

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Created On 09/17/24 21:21 PM - Last Modified 10/02/24 23:58 PM


Symptom


  • Alerte concernant l’épuisement de la mémoire de processus pour « snmpd »


Environment


  • Pan-OS


Cause


Un épuisement de la mémoire dans le processus « snmpd » a été détecté.



Resolution


  1. Rassemblez les données suivantes nécessaires pour diagnostiquer la cause de l’épuisement de la mémoire snmpd :
    1. Collectez le fichier de support technique à partir de l’interface utilisateur : Support > périphérique > Générer un fichier de support technique.

    2. Exécutez les commandes CLI suivantes pour rassembler les fichiers principaux :

      debug software core snmpd

      Téléchargez les fichiers principaux à partir de l’interface utilisateur : Prise en charge > l’appareil > Télécharger les fichiers principaux.

    3. Exportez l’état de l’appareil à partir de l’interface utilisateur : Configuration > opérations > l’appareil > Exporter l’état de l’appareil.
    4. Recueillez des données à partir de Strata Cloud Manager, telles que la date de début de l’épuisement de la mémoire et toute modification de configuration ou de logiciel effectuée pendant cette période.
    5. Ouvrez un dossier d’assistance avec les données ci-dessus.
  2. Utilisez les étapes d’atténuation suivantes comme correctif temporaire :
    1. Redémarrez le processus snmpd pour réduire l’utilisation de la mémoire à l’aide de la commande :
      debug software restart process snmpd
      Remarque :
    • Cette action est recommandée lors d’une fenêtre de maintenance.
    • Le redémarrage de snmpd atténue temporairement la croissance de la mémoire, mais le problème peut se reproduire.

 


Additional Information


PAN-217208 : Correction d’un problème où une fuite de mémoire liée au processus snmpd provoquait une condition de mémoire insuffisante (OOM) ou provoquait le redémarrage du processus lors de l’utilisation de SNMPv3. ( (Corrigé dans les versions 10.1.9-h9, 10.1.10-h4 ou 10.1.11 ou ultérieure).

Si le pare-feu ou Panorama est affecté par le problème logiciel PAN-217208, effectuez une mise à niveau vers une version avec le correctif ou une version ultérieure, ou utilisez la solution de contournement consistant à désactiver SNMPv3 et à utiliser SNMPv2 à la place.

Pour plus de détails sur l’épuisement de la mémoire qui affecte les pare-feu ou Panorama configuré pour utiliser SNMPv3, reportez-vous à la section Échecs d’interrogation SNMPV3 et messages OOM dans le journal système



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