Agotamiento de la memoria del proceso - Snmpd
Symptom
- Alerta sobre el agotamiento de la memoria del proceso para "snmpd"
Environment
- PAN-os
Cause
Se encontró un agotamiento de memoria en el proceso "snmpd".
Resolution
- Reúna los siguientes datos necesarios para diagnosticar la causa del agotamiento de la memoria snmpd:
-
Recopilar archivo de soporte técnico de la interfaz de usuario: Soporte > dispositivo > Generar archivo de soporte técnico.
-
Ejecute los siguientes comandos de la CLI para recopilar los archivos principales:
debug software core snmpd
Descargue los archivos principales de la interfaz de usuario: Compatibilidad con dispositivos > > Descargar archivos principales.
- Exporte el estado del dispositivo desde la interfaz de usuario: Configuración del dispositivo > > operaciones > Exportar estado del dispositivo.
- Recopile datos de Strata Cloud Manager, como la fecha de inicio del agotamiento de la memoria y cualquier cambio de configuración o software realizado durante ese tiempo.
- Abra un caso de soporte con los datos anteriores.
-
- Use los siguientes pasos de mitigación como solución temporal:
- Reinicie el proceso snmpd para reducir el uso de memoria mediante el comando:
debug software restart process snmpd
Nota:
- Esta acción se recomienda durante un período de mantenimiento.
- Reiniciar
snmpdmitiga temporalmente el crecimiento de la memoria, pero el problema puede volver a ocurrir.
- Reinicie el proceso snmpd para reducir el uso de memoria mediante el comando:
Additional Information
PAN-217208: Se ha corregido un problema por el que una pérdida de memoria relacionada con el proceso snmpd provocaba una condición de memoria insuficiente (OOM) o provocaba que el proceso se reiniciara al utilizar SNMPv3. ( (Solucionado en 10.1.9-h9,10.1.10-h4 o 10.1.11 o versiones posteriores).
Si el firewall o Panorama se ven afectados por el problema de software PAN-217208, actualice a una versión con la corrección o a una versión posterior, o utilice la solución alternativa de deshabilitar SNMPv3 y usar SNMPv2 en su lugar.
Para obtener más información sobre el agotamiento de la memoria que afecta a los firewalls o a Panorama configurado para usar SNMPv3, consulte Errores de sondeo de SNMPV3 y mensajes OOM en el registro del sistema