Agotamiento de la memoria del proceso - Snmpd

Agotamiento de la memoria del proceso - Snmpd

3935
Created On 09/17/24 21:21 PM - Last Modified 10/02/24 23:58 PM


Symptom


  • Alerta sobre el agotamiento de la memoria del proceso para "snmpd"


Environment


  • PAN-os


Cause


Se encontró un agotamiento de memoria en el proceso "snmpd".



Resolution


  1. Reúna los siguientes datos necesarios para diagnosticar la causa del agotamiento de la memoria snmpd:
    1. Recopilar archivo de soporte técnico de la interfaz de usuario: Soporte > dispositivo > Generar archivo de soporte técnico.

    2. Ejecute los siguientes comandos de la CLI para recopilar los archivos principales:

      debug software core snmpd

      Descargue los archivos principales de la interfaz de usuario: Compatibilidad con dispositivos > > Descargar archivos principales.

    3. Exporte el estado del dispositivo desde la interfaz de usuario: Configuración del dispositivo > > operaciones > Exportar estado del dispositivo.
    4. Recopile datos de Strata Cloud Manager, como la fecha de inicio del agotamiento de la memoria y cualquier cambio de configuración o software realizado durante ese tiempo.
    5. Abra un caso de soporte con los datos anteriores.
  2. Use los siguientes pasos de mitigación como solución temporal:
    1. Reinicie el proceso snmpd para reducir el uso de memoria mediante el comando:
      debug software restart process snmpd
      Nota:
    • Esta acción se recomienda durante un período de mantenimiento.
    • Reiniciar snmpd mitiga temporalmente el crecimiento de la memoria, pero el problema puede volver a ocurrir.

 


Additional Information


PAN-217208: Se ha corregido un problema por el que una pérdida de memoria relacionada con el proceso snmpd provocaba una condición de memoria insuficiente (OOM) o provocaba que el proceso se reiniciara al utilizar SNMPv3. ( (Solucionado en 10.1.9-h9,10.1.10-h4 o 10.1.11 o versiones posteriores).

Si el firewall o Panorama se ven afectados por el problema de software PAN-217208, actualice a una versión con la corrección o a una versión posterior, o utilice la solución alternativa de deshabilitar SNMPv3 y usar SNMPv2 en su lugar.

Para obtener más información sobre el agotamiento de la memoria que afecta a los firewalls o a Panorama configurado para usar SNMPv3, consulte Errores de sondeo de SNMPV3 y mensajes OOM en el registro del sistema



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000HE77CAG&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language