Process Memory Depletion - Snmpd
Symptom
- Alert regarding process memory depletion for "snmpd"
Environment
- PAN-OS
Cause
A memory depletion in the "snmpd" process was found.
Resolution
- Gather the following data required to diagnose the cause of snmpd memory depletion:
-
Collect Tech Support File from the UI: Device > Support > Generate Tech Support File.
-
Run the following CLI commands to gather the core files:
debug software core snmpd
Download the core files from the UI: Device > Support > Download Core Files.
- Export the Device State from the UI: Device > Setup > Operations > Export Device State.
- Gather data from Strata Cloud Manager, such as the memory depletion start date and any configuration or software changes made during that time.
- Open a support case with the above data.
-
- Use the following mitigation steps as a temporary fix:
- Restart the snmpd process to reduce the memory usage by using the command:
debug software restart process snmpd
Note:
- This action is recommended during a maintenance window.
- Restarting
snmpdtemporarily mitigates memory growth, but the issue may reoccur.
- Restart the snmpd process to reduce the memory usage by using the command:
Additional Information
PAN-217208: Fixed an issue where a memory leak related to the snmpd process caused an out-of-memory (OOM) condition or caused the process to restart when using SNMPv3. ( (Fixed in 10.1.9-h9,10.1.10-h4 or 10.1.11 or later release).
If the firewall or Panorama is affected by software issue PAN-217208, upgrade to a release with the fix or a later version, or use the workaround of disabling SNMPv3 and using SNMPv2 instead.
For more details about the memory depletion that affects firewalls or Panorama configured to use SNMPv3 refer to SNMPV3 polling failures and OOM messages in system log