Erschöpfung des Prozessspeichers - Snmpd
Symptom
- Warnung bezüglich Erschöpfung des Prozessspeichers für "snmpd"
Environment
- Pan-OS
Cause
Es wurde eine Speichererschöpfung im "snmpd"-Prozess festgestellt.
Resolution
- Sammeln Sie die folgenden Daten, die erforderlich sind, um die Ursache der snmpd-Speichererschöpfung zu diagnostizieren:
-
Erfassen Sie die Tech-Support-Datei über die Benutzeroberfläche: Device > Support > Generate Tech Support-Datei.
-
Führen Sie die folgenden CLI-Befehle aus, um die Kerndateien zu sammeln:
debug software core snmpd
Laden Sie die Kerndateien von der Benutzeroberfläche herunter: Geräte- > > Kerndateien herunterladen.
- Exportieren Sie den Gerätestatus über die Benutzeroberfläche: Gerät > Setup- > Vorgänge > Gerätestatus exportieren.
- Erfassen Sie Daten von Strata Cloud Manager, wie z. B. das Startdatum der Speichererschöpfung und alle Konfigurations- oder Softwareänderungen, die während dieser Zeit vorgenommen wurden.
- Öffnen Sie einen Supportfall mit den oben genannten Daten.
-
- Verwenden Sie die folgenden Schritte zur Risikominderung als vorübergehende Lösung:
- Starten Sie den snmpd-Prozess neu, um die Speicherauslastung zu reduzieren, indem Sie den folgenden Befehl verwenden:
debug software restart process snmpd
Hinweis:
- Diese Aktion wird während eines Wartungsfensters empfohlen.
- Durch einen Neustart von
snmpdwird das Speicherwachstum vorübergehend gemildert, das Problem kann jedoch erneut auftreten.
- Starten Sie den snmpd-Prozess neu, um die Speicherauslastung zu reduzieren, indem Sie den folgenden Befehl verwenden:
Additional Information
PAN-217208: Es wurde ein Problem behoben, bei dem ein Speicherleck im Zusammenhang mit dem snmpd-Prozess einen Out-of-Memory-Zustand (OOM) verursachte oder dazu führte, dass der Prozess neu gestartet wurde, wenn SNMPv3 verwendet wurde. ( (Behoben in Version 10.1.9-h9, 10.1.10-h4 oder 10.1.11 oder höher).
Wenn die Firewall oder Panorama vom Softwareproblem PAN-217208 betroffen ist, aktualisieren Sie auf eine Version mit dem Fix oder eine höhere Version, oder verwenden Sie die Problemumgehung, indem Sie SNMPv3 deaktivieren und stattdessen SNMPv2 verwenden.
Weitere Informationen zur Speichererschöpfung, die sich auf Firewalls oder Panorama auswirkt, die für die Verwendung von SNMPv3 konfiguriert sind, finden Sie unter SNMPV3-Abfragefehler und OOM-Meldungen im Systemprotokoll