Android GlobalProtect app with always-on mode does not start automatically after upgrade via MDM

Android GlobalProtect app with always-on mode does not start automatically after upgrade via MDM

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Created On 08/22/24 07:00 AM - Last Modified 08/23/24 20:23 PM


Symptom


  • Android GlobalProtect App with always-on mode upgraded via MDM 
  • After upgrade the app does not start automatically


Environment


  • GlobalProtect (GP) App on Android devices
  • Upgrade via MDM (Mobile Device Management)


Cause


GlobalProtect App upgrade is not handled by the GP Portal and so the GP portal has no control over the trigger of VPN. It is handled by MDM.

Resolution


Manually start the application (as all other applications do).

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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000HDwnCAG&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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