Prisma Cloud Computing : échec de l'authentification SAML 500 erreur interne du serveur, l'affirmation n'est pas encore valide

Prisma Cloud Computing : échec de l'authentification SAML 500 erreur interne du serveur, l'affirmation n'est pas encore valide

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Created On 07/30/24 18:03 PM - Last Modified 02/06/25 18:36 PM


Symptom


Cela se produit lorsque le temps de calcul du pod/nœud du cloud Prisma est supérieur à 5 minutes avec l'équilibreur de charge/le serveur Kerberos /le serveur SAML, puis l'authentification échoue.

sortie de la console.logs

DEBU 2024-07-30T17:04:28.029 route_handler.go:3256 Authenticating saml user type: otherProvider                                                                                        
ERRO 2024-07-30T17:04:28.046 route_handler.go:3308 Failed to authenticate using authentication endpoint, error: failed to check if saml user exists: assertion is not yet valid        ERRO 2024-07-30T17:04:28.047 route_handler.go:14504 Operation failed: uri=/api/v1/authenticate; error=failed to check if saml user exists: assertion is not yet valid



Environment


SaaS cloud Prisma
Prima Cloud Computing auto-hébergé


Cause


Lorsque le temps du serveur Kerberos /serveur d'authentification SAML est supérieur à 5 minutes avec le pod/nœud de calcul cloud Prisma, cette erreur se produit

Resolution


  1. Vérifiez que la différence de temps est supérieure à 5 minutes entre le pod/nœud de calcul cloud Prisma.
  2. Vérifiez l'heure sur le serveur NTP /serveur Kerberos /serveur d'authentification SAML.
  3. Essayez d'utiliser le serveur NTP pour le cloud computing Prisma et le serveur d'authentification SAML, par exemple, pour résoudre le problème.
  4. OU
  5. Ajustez l'heure à l'aide de la commande « date » sur le pod de calcul cloud Prisma pour la faire correspondre au serveur d'authentification SAML.


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