Prisma cloud computing: Error de autenticación SAML 500: la afirmación de error interno del servidor aún no es válida
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Created On 07/30/24 18:03 PM - Last Modified 02/06/25 18:36 PM
Symptom
Esto ocurre cuando el tiempo del nodo/pod de cómputo en la nube Prisma tiene una diferencia de tiempo de >5 minutos con el balanceador de carga/servidor Kerberos /servidor SAML, y luego falla la autenticación.
salida de console.logs
DEBU 2024-07-30T17:04:28.029 route_handler.go:3256 Authenticating saml user type: otherProvider ERRO 2024-07-30T17:04:28.046 route_handler.go:3308 Failed to authenticate using authentication endpoint, error: failed to check if saml user exists: assertion is not yet valid ERRO 2024-07-30T17:04:28.047 route_handler.go:14504 Operation failed: uri=/api/v1/authenticate; error=failed to check if saml user exists: assertion is not yet valid
Environment
Prisma nube SaaS
Computación en la nube Prima autoalojada
Cause
Cuando el tiempo del servidor Kerberos /servidor de autenticación SAML varía más de 5 minutos con el pod/nodo de computación en la nube Prisma, se produce este error.
Resolution
- Verifique que la diferencia horaria sea >5 minutos entre el nodo/pod de cómputo en la nube de Prisma.
- Verifique la hora en el servidor NTP /servidor Kerberos /servidor de autenticación SAML.
- Intente utilizar el servidor NTP tanto para Prisma Cloud Computing como para el servidor de autenticación SAML para resolver el problema.
- O
- Ajuste la hora usando el comando ?date? en el pod de cómputo en la nube prisma para que coincida con el servidor de autenticación SAML.