Prisma Cloud Compute: SAML-Authentifizierung fehlgeschlagen 500 Interner Serverfehler Behauptung ist noch nicht gültig
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Created On 07/30/24 18:03 PM - Last Modified 02/06/25 18:36 PM
Symptom
Dies tritt auf, wenn die Zeit des Prisma-Cloud-Compute-Pods/-Knotens >5 Minuten vom Load Balancer/ Kerberos Server/SAML-Server abweicht und die Authentifizierung dann fehlschlägt.
Ausgabe aus den console.logs
DEBU 2024-07-30T17:04:28.029 route_handler.go:3256 Authenticating saml user type: otherProvider ERRO 2024-07-30T17:04:28.046 route_handler.go:3308 Failed to authenticate using authentication endpoint, error: failed to check if saml user exists: assertion is not yet valid ERRO 2024-07-30T17:04:28.047 route_handler.go:14504 Operation failed: uri=/api/v1/authenticate; error=failed to check if saml user exists: assertion is not yet valid
Environment
Prisma Cloud SaaS
Prima Cloud-Computing selbst gehostet
Cause
Dieser Fehler tritt auf, wenn die Zeit des Kerberos -Servers/SAML-Authentifizierungsservers mit dem Prisma-Cloud-Compute-Pod/-Knoten >5 Minuten abweicht.
Resolution
- Überprüfen Sie, ob der Zeitunterschied zwischen den Prisma-Cloud-Compute-Pods und -Knoten mehr als 5 Minuten beträgt.
- Überprüfen Sie die Zeit auf dem NTP Server/ Kerberos Server/SAML-Authentifizierungsserver.
- Versuchen Sie, den NTP -Server sowohl für Prisma Cloud Compute als auch für den SAML-Authentifizierungsserver zu verwenden, um das Problem zu beheben.
- ODER
- Passen Sie die Uhrzeit mit dem Befehl „date“ auf dem Prisma Cloud Compute Pod an, um sie mit dem SAML-Authentifizierungsserver abzugleichen.