Cortex XDR: La función de visor predeterminada muestra "Error al ejecutar la consulta" en el panel con widgets personalizados

Cortex XDR: La función de visor predeterminada muestra "Error al ejecutar la consulta" en el panel con widgets personalizados

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Created On 06/17/24 13:33 PM - Last Modified 08/14/24 01:48 AM


Symptom


  • Los usuarios a los que se les concede el rol XDR de Cortex predeterminado denominado Visor pueden tener problemas para ver los paneles o cualquier widget basado en consultas XQL que ejecute el widget.
    • Esto puede presentar los dos errores:
      • "No se pudo ejecutar la consulta"
      • Aviso de permiso: su rol actual le impide utilizar todos los componentes de esta página. Póngase en contacto con su administrador para ajustar sus permisos de acceso".


Environment


  • Cortex XDR o XDR


Cause


  • Los widgets que utiliza un panel predeterminado o un panel personalizado pueden ejecutarse en consultas XQL
  • De forma predeterminada, el rol de visor otorga acceso de solo lectura a las actividades del Centro de consultas, mientras que Ver/Editar es necesario para ver cualquier widget que esté ejecutando consultas XQL, ya que técnicamente se vuelve a ejecutar en el momento de ver el panel
  • Cualquier usuario con solo el rol de visor no podrá ver ningún widget que ejecute consultas XQL por este motivo, dando el error "Error al ejecutar la consulta" que luego genera el error "Aviso de permiso: su rol actual le impide usar todos los componentes de esta página. Póngase en contacto con su administrador para ajustar sus permisos de acceso." en la parte superior de la pantalla


Resolution


Los administradores del inquilino pueden clonar el rol de visor y editar para tener permisos de vista/edición para el Centro de consultas:
  1. Inicie sesión en el inquilino
  2. Vaya a Configuración > Configuraciones > Administración de acceso > roles
  3. Busque la función de visor , haga clic con el botón derecho y seleccione Guardar como nueva función
  4. Proporcione un nombre de rol, en Respuesta a incidentes > Investigación > Centro de consultas, seleccione Ver/Editar y haga clic en Guardar
  5. Vaya a Configuración > Configuraciones > Administración de acceso > usuarios y haga clic con el botón derecho en el usuario, seleccione Editar permisos de usuario
  6. Establezca el rol del usuario como el rol personalizado recién creado y haga clic en Guardar


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