Cortex XDR: Die Standard-Viewer-Rolle zeigt "Fehler beim Ausführen der Abfrage" im Dashboard mit benutzerdefinierten Widgets an

Cortex XDR: Die Standard-Viewer-Rolle zeigt "Fehler beim Ausführen der Abfrage" im Dashboard mit benutzerdefinierten Widgets an

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Created On 06/17/24 13:33 PM - Last Modified 08/14/24 01:48 AM


Symptom


  • Benutzer, denen die standardmäßige Cortex-XDR-Rolle mit dem Namen Viewer zugewiesen wurde, können Probleme beim Anzeigen von Dashboards oder Widgets haben, die auf XQL-Abfragen basieren, die vom Widget ausgeführt werden.
    • Dies kann die beiden folgenden Fehler verursachen:
      • "Fehler beim Ausführen der Abfrage"
      • Berechtigungshinweis - Ihre aktuelle Rolle hindert Sie daran, alle Komponenten auf dieser Seite zu verwenden. Wenden Sie sich an Ihren Administrator, um Ihre Zugriffsberechtigungen anzupassen."


Environment


  • Cortex XDR oder XDR


Cause


  • Widgets, die entweder von einem Standard-Dashboard oder einem benutzerdefinierten Dashboard verwendet werden, können auf XQL-Abfragen ausgeführt werden
  • Standardmäßig gewährt die Rolle "Betrachter" schreibgeschützten Zugriff auf die Query Center-Aktivitäten, während Anzeigen/Bearbeiten erforderlich ist, um alle Widgets anzuzeigen, die XQL-Abfragen ausführen, da sie technisch gesehen zum Zeitpunkt der Anzeige des Dashboards erneut ausgeführt werden
  • Jeder Benutzer, der nur über die Rolle "Betrachter" verfügt, kann aus diesem Grund keine Widgets anzeigen, auf denen XQL-Abfragen ausgeführt werden, und gibt den Fehler "Fehler beim Ausführen der Abfrage" aus, der dann den Fehler "Berechtigungshinweis - Ihre aktuelle Rolle hindert Sie daran, alle Komponenten auf dieser Seite zu verwenden" generiert. Wenden Sie sich an Ihren Administrator, um Ihre Zugriffsberechtigungen anzupassen." oben auf dem Bildschirm


Resolution


Administratoren des Mandanten können die Rolle "Betrachter" klonen und bearbeiten, um über Anzeige-/Bearbeitungsberechtigungen für Query Center zu verfügen:
  1. Melden Sie sich bei Ihrem Mandanten an
  2. Navigieren Sie zu Einstellungen > Konfigurationen > Zugriffsverwaltung > Rollen
  3. Suchen Sie die Betrachterrolle, klicken Sie mit der rechten Maustaste und wählen Sie Als neue Rolle speichern aus.
  4. Geben Sie einen Rollennamen ein, wählen Sie unter Incident Response > Investigation > Query Center die Option Anzeigen/Bearbeiten aus und klicken Sie auf Speichern
  5. Navigieren Sie zu Einstellungen > Konfigurationen > Zugriffsverwaltung > Benutzer, klicken Sie mit der rechten Maustaste auf den Benutzer und wählen Sie Benutzerberechtigungen bearbeiten aus.
  6. Legen Sie die Rolle des Benutzers als neu erstellte benutzerdefinierte Rolle fest und klicken Sie auf Speichern


Actions
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