GlobalProtect SAML authentification avec embedded browser coincé après la mise à jour Adobe Acrobat Reader à la version 21.001.20135
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Created On 02/12/21 20:49 PM - Last Modified 05/06/22 20:49 PM
Symptom
Adobe Acrobat Reader mise à jour - version 21.001.20135 rompt le processus SAML d’authentification et provoque GlobalProtect l’échec de la connexion. Une fois que l’utilisateur entre ses informations d’identification sur le navigateur intégré, la fenêtre SAML d’authentification est coincée dans l’état de connexion et GlobalProtect l’application affiche un message d’erreur (comme indiqué ci-dessous) concernant un plug-in Adobe.
(Remarque : Le message d’erreur n’apparaît pas automatiquement. L’utilisateur devra planer au-dessus de GP l’icône sur la barre des tâches pour voir le message d’erreur).
Environment
- GlobalProtect Version de l’application: Tout
- Méthode d’authentification : SAML
- Navigateur utilisé pour SAML l’authentification : Intégré
- Adobe Acrobat Reader Version: 21.001.20135
- OS: Points d’évaluation Windows
Cause
Ce problème est NOT causé par GlobalProtect l’application. Adobe Acrobat Reader mise à jour 21.001.20135 installe Plugins dans les navigateurs. Mais, ce nouveau plugin n’est pas pris en charge par le navigateur intégré qui est utilisé par App pour GlobalProtect l’authentification. SAML Par conséquent, les pauses SAML d’authentification provoquent GlobalProtect l’échec de la connexion App. VPND’autres fournisseurs sont également confrontés à un problème similaire. Vous pouvez voir des discussions à ce sujet sur la communauté Adobe dans les liens suivants:
https://community.adobe.com/t5/acrobat-reader/bug-version-21-001-20135/td-p/11821802
https://community.adobe.com/t5/acrobat-reader/adobe-acrobat-reader-21-001-20135-preventing-users-to-connect-to-global-protect/td-p/11823885
Resolution
Adode a résolu ce problème avec une version hotfix 21.001.20138. Pour plus de détails, référez-vous à ce lien - https://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotesDC/continuous/dccontinuousfeb2021qfe.html Si
vous n’êtes pas en mesure de mettre à niveau la version Adode Acrobat Reader au 21.001.20138, vous pouvez utiliser les solutions de contournement énumérées ci-dessous pour résoudre ce problème.
- Rétrograder Adobe Acrobat Reader à la version précédente.
- Désactiver plugin lecteur Adobe PDF à partir du IE navigateur. Pour ce faire, allez à Internet Explorer, puis les paramètres > gérer add-on puis choisir tous les add-ons et choisir Adobe Reader et cliquez à droite sur elle, puis PDF cliquez sur désactiver pour le désactiver.
- Utilisez le navigateur système par défaut (comme Chrome, IE Firefox, etc) pour l’authentification, SAML consultez ce lien pour plus de détails.Cette fonctionnalité est prise en GlobalProtect charge sur la version app 5.2.0 ou plus tard et PAN-OS 8.1.17, 9.0.11, 9.1.6, et 10.0.0 ou plus tard avec la version de sortie de contenu 8284-6139 ou plus tard.
Additional Information
Veuillez contacter l’équipe de soutien de Palo Alto Networks si vous avez d’autres questions.