GlobalProtect SAML Authentifizierung mit Embedded Browser nach der Aktualisierung von Adobe Acrobat Reader auf Version 21.001.20135

GlobalProtect SAML Authentifizierung mit Embedded Browser nach der Aktualisierung von Adobe Acrobat Reader auf Version 21.001.20135

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Created On 02/12/21 20:49 PM - Last Modified 05/06/22 20:49 PM


Symptom


Adobe Acrobat Reader-Update – Version 21.001.20135 bricht SAML den Authentifizierungsprozess und führt zu GlobalProtect einem Verbindungsfehler. Sobald der Benutzer seine Anmeldeinformationen im eingebetteten Browser eingibt, bleibt das SAML Authentifizierungsfenster im Verbindungszustand hängen, und die GlobalProtect App zeigt eine Fehlermeldung (wie unten gezeigt) in Bezug auf ein Adobe-Plug-In an.
 
GP Fehler Adobe

Adobe-Fehler

(Hinweis: Die Fehlermeldung wird nicht automatisch angezeigt. Der Benutzer muss mit der Maus auf das GP Symbol auf der Taskleiste zeigen, um die Fehlermeldung anzuzeigen).
  
   


Environment


  • GlobalProtect App-Version: Beeine
  • Authentifizierungsmethode: SAML
  • Browser für SAML die Authentifizierung: Eingebettet
  • Adobe Acrobat Reader Version: 21.001.20135
  • OS: Windows-Endpunkte

 


Cause


Dieses Problem wird NOT durch GlobalProtect die App verursacht. Adobe Acrobat Readers Update 21.001.20135 installiert Plugins in den Browsern. Aber, Dieses neue Plugin wird nicht von der eingebetteten Browser unterstützt, die von App für die Authentifizierung verwendet GlobalProtect SAML wird. Daher bricht die SAML Authentifizierung unterbrechungsweise, wodurch die GlobalProtect App-Verbindung fehlschlägt. Auch andere VPN Anbieter stehen vor einem ähnlichen Problem. Sie können Diskussionen rund um diese in der Adobe-Community unter den folgenden Links sehen:

https://community.adobe.com/t5/acrobat-reader/bug-version-21-001-20135/td-p/11821802
https://community.adobe.com/t5/acrobat-reader/adobe-acrobat-reader-21-001-20135-preventing-users-to-connect-to-global-protect/td-p/11823885

  


Resolution


Adode hat dieses Problem mit einer Hotfix-Version 21.001.20138 behoben. Weitere Informationen finden Sie unter diesem Link - https://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotesDC/continuous/dccontinuousfeb2021qfe.html

Wenn Sie die Adode Acrobat Reader-Version nicht auf 21.001.20138 aktualisieren können, können Sie die unten aufgeführten Problemumgehungen verwenden, um dieses Problem zu beheben.
  • Downgrade von Adobe Acrobat Reader auf die vorherige Version.
  • Deaktivieren Sie das Adobe PDF Reader Plugin im IE Browser. Um dies zu tun, gehen Sie zu Internet Explorer und dann Einstellungen > verwalten Add-on dann wählen Sie Alle Add-ons und wählen Sie Adobe Reader und klicken Sie PDF mit der rechten Maustaste darauf dann klicken Sie auf deaktivieren, um es zu deaktivieren.
 Adobe PDF Reader deaktivieren
  • Verwenden Sie den Standard-Systembrowser (wie Chrome, IE , Firefox, etc.) für die SAML Authentifizierung, überprüfen Sie diesen Link für weitere Details.Diese Funktion wird auf GlobalProtect App-Version 5.2.0 oder höher und PAN-OS 8.1.17, 9.0.11, 9.1.6 und 10.0.0 oder höher mit Content Release Version 8284-6139 oder höher unterstützt.


Additional Information


Bei weiteren Fragen wenden Sie sich bitte an das Palo Alto Networks Support-Team.

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