Why does "Hit Count" gets reset when renaming the security rule, on PAN-OS 8.1 and below.

Why does "Hit Count" gets reset when renaming the security rule, on PAN-OS 8.1 and below.

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Created On 01/25/21 23:15 PM - Last Modified 10/15/21 19:03 PM


Symptom


  • On PAN -OS 8.1, the "Hit Count" value will be reset when the security policy is renamed.


Environment


  • PAN-OS 8.1 and earlier.


Cause


This is expected behavior because on PAN-OS 8.1, the "Rule Usage" data is tracked based the security rule's name, so when the name changes the "Rule Usage" data gets reset.
In contrast, this is not the expected behavior for PAN-OS 9.0 and above due to the introduction of "Universally Unique Identifier" or UUID, and so starting with PAN-OS 9.0, the "Rule Usage" data is no longer tracked by the name of the rule but by its UUID, so renaming the rule on PAN-OS 9.0 and above will not cause for the "Rule Usage" data to be reset.


 


Resolution


  • Upgrade tp PAN-OS 9.0 or above.
Note: The "Rule Usage" data will also be reset when upgrading from 8.1 to 9.0 or above due to the introduction of the UUID. However, once the device has been upgraded to 9.0 or above, the "Rule Usage" data should be kept (not reset) across further upgrades/downgrades, except when downgrading below 9.0.


Additional Information


Please refer to the following document for more information on UUID:
Universally Unique Identifiers for Policy Rules


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