SAML " DUO " Authentifizierung schlägt auf GlobalProtect Linux-Clients fehl, wenn Zertifikat manuell auf vertrauenswürdigen Endpunkten bereitgestellt wird
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Created On 01/18/21 20:21 PM - Last Modified 03/26/21 18:55 PM
Symptom
- SAML " DUO " Authentifizierung schlägt auf Linux Global Protect fehl, wenn das manuelle Zertifikat für vertrauenswürdige Endpunkte auf dem Linux-Computer bereitgestellt wird.
- Nach der Eingabe der Anmeldeinformationen für SAML sie kann das vertrauenswürdige Endpunktzertifikat, das auf dem Computer installiert ist, nicht überprüft werden.
Environment
- Linux Global Protect
- SAML Duo-Authentifizierung
- Global Protect Version 5.2.0 und höher
Cause
- Die Einschränkung mit dem eingebetteten Browser, der vom Linux-Computer verwendet wird, bei dem der SAML Global Protect-Client das auf dem Computer installierte vertrauenswürdige Endpunktzertifikat nicht überprüfen kann und die Authentifizierung fehlgeschlagen ist.
Resolution
- Konfigurieren der Standardbrowsereinstellung für die SAML Authentifizierung
- Ändern Sie "Standardbrowser für SAML die Authentifizierung verwenden" in "Ja" unter der Portal-App-Konfiguration, indem Sie zu Netzwerk-> > Portals navigieren GlobalProtect > "Wählen Sie Ihr Portal" > Agent > "Client Config auswählen" > App und wählen Sie OK
- Legen Sie unter Linux-Endpunkten den Standard-Browserwert in der Konfigurationsdatei /opt/paloaltonetworks/ globalprotect /pangps.xml Vorbereitstellungskonfigurationsdatei unter auf yes <settings></settings> fest.
- Nachdem Sie den Standardbrowserwert hinzugefügt haben, müssen Sie den Linux-Endpunkt neu starten, damit die Änderung wirksam wird.
- Jetzt verwendet der Linux Global Protect-Client den Standardbrowser für die SAML Duo-Authentifizierung und kann das auf dem Computer installierte vertrauenswürdige Endpunktzertifikat überprüfen, und die Authentifizierung wird erfolgreich.