No se puede actualizar GlobalProtect la aplicación debido a la firma corrupta

No se puede actualizar GlobalProtect la aplicación debido a la firma corrupta

13047
Created On 11/04/20 18:04 PM - Last Modified 05/29/25 03:16 AM


Symptom


  • No se puede actualizar GlobalProtect la aplicación
  • Observe el siguiente error dentro del archivo PanGPS.log o algo similar en los registros del sistema WebUI:
(T10256) Error( 165): 05/21/20 23:35:03:335 El archivo C:\Users\hellc\AppData\Local\Temp\_temp19536.msi es no firmado o dañado
(T10256)Error( 634): 05/21/20 23:35:03:335 archivo no firmado por nosotros, retorno ahora

 


Environment


  • GlobalProtect Infraestructura desplegada
  • Entorno Windows AD
  • GlobalProtect Aplicación 


Cause


Este problema puede deberse a varias razones, pero en este escenario en particular el problema se debe a una entrada incorrecta DNS para el GlobalProtect Portal

Resolution


  1. En este escenario en particular, el cliente utilizó 2 DNS entradas separadas para su Portal FQDN que dan como resultado respuestas diferentes cuando está conectado en lugar de desconectarse: por ejemplo conectado (10.*)y desconectado (12.*)
  2. Sin embargo, durante el proceso de actualización, la dirección del Portal IP debe resolverse en la misma IP dirección que se incluye en el archivo de configuración que era la dirección interna privada (10.*) en lugar de la dirección pública externa IP (12.*)
Nota: Este es un fragmento de código del archivo de soporte técnico recuperado del Portal firewall
 
<global-protect-portal>
<entry name="PDX-VPN">
<portal-config>
<local-address>
<ip>
<ipv4>10.50.51.2/29</ipv4>
</ip>
<interface>ethernet1/1</interface>
</local-address>

  1. Cada intento de actualización mientras estaba fuera de la red resultó en un error que indicaba que el archivo no estaba firmado o dañado dentro del archivo PanGPS.log como se muestra a continuación:
(T10256) Información ( 604): 05/21/20 23:35:03:332 #### actualizador iniciado, el comando es C:\Users\hellc\AppData\Local\Temp\_temp19536.msi
(T10256)Debug( 39): 05/21/20 23:35:03:332 intente verificar el archivo C:\Users\hellc\AppData\Local\Temp\_temp19536.msi
T10256)Error( 165): 05/21/20 23:35:03:335 El archivo C:\Users\hellc\AppData\Local\Temp\_temp19536.msi no está firmado ni dañado
(T10256)Error( 634): 05/21/20 23:35:03:335 archivo no firmado por nosotros, retorno ahora
 
  1. Confirmamos las sumas de comprobación md5 coincidentes entre el archivo temporal en el equipo del usuario y lo que se inserta desde el servidor de actualización de Palo Alto Networks para las versiones, pero al intentar iniciar el archivo se rellena un error 404 como se muestra a continuación como:
Instantánea del error de página 404 visto por el cliente al iniciar el archivo descargado temporal

 
  1. Al hacer que el cliente intentara activar el proceso de descarga manualmente navegando a https://<portal’s ip="" or="" fqdn="">/global-protect/getmsi.esp</portal’s> nos dimos cuenta de que la url se resolvía para separar IP 's y solicitamos al cliente que resolviera el Portal utilizando solo la dirección pública IP en lugar de tener 2 entradas separadas para usuarios internos y usuarios externos.
  2. Al cambiar esto para resolver sólo usando el externo (12.*) IP dirección, la GlobalProtect aplicación fue capaz de actualizar sin problemas


Additional Information




Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000HBW9CAO&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language