App kann aufgrund einer beschädigten Signatur nicht aktualisiert GlobalProtect werden
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Created On 11/04/20 18:04 PM - Last Modified 05/29/25 03:16 AM
Symptom
- App kann nicht aktualisiert GlobalProtect werden
- Beachten Sie den folgenden Fehler in der PanGPS.log-Datei oder ähnlichem in den WebUI-Systemprotokollen:
(T10256) Fehler( 165): 05/21/20 23:35:03:335 Die Datei C: 'Users'hellc'AppData'Local'Temp'_temp19536.msi ist nicht signiert oder beschädigt
(T10256)Error( 634): 05/21/20 23:35:03:335 Datei wurde nicht von uns signiert, jetzt zurück
(T10256)Error( 634): 05/21/20 23:35:03:335 Datei wurde nicht von uns signiert, jetzt zurück
Environment
- GlobalProtect Bereitgestellte Infrastruktur
- ADWindows-Umgebung
- GlobalProtect App
Cause
Dieses Problem kann durch mehrere Gründe verursacht werden, aber in diesem speziellen Szenario wird das Problem durch einen falschen DNS Eintrag für das Portal verursacht. GlobalProtect
Resolution
- In diesem speziellen Szenario verwendete der Kunde 2 separate DNS Einträge für sein Portal, was zu FQDN unterschiedlichen Antworten führte, wenn eine Verbindung hergestellt und nicht getrennt wurde: z.B. verbunden (10.*)und getrennt (12.*)
- Während des Aktualisierungsvorgangs muss die Adresse des Portals jedoch IP in dieselbe Adresse aufgelöst werden, die in der IP Konfigurationsdatei enthalten ist, die die private interne Adresse (10.*) und nicht die externe öffentliche IP Adresse (12.*) war.
Hinweis: Dies ist ein Ausschnitt aus der Tech-Support-Datei, die aus dem Portal abgerufen wurde. firewall
<global-protect-portal>
<entry name="PDX-VPN">
<portal-config>
<local-address>
<ip>
<ipv4>10.50.51.2/29</ipv4>
</ip>
<interface>ethernet1/1</interface>
</local-address>
- Jeder Aktualisierungsversuch außerhalb des Netzwerks führte zu einem Fehler, der besagte, dass die Datei in der PanGPS.log-Datei nicht signiert oder beschädigt war, wie unten gezeigt:
(T10256) Info ( 604): 05/21/20 23:35:03:332 -Updater gestartet, Befehl ist C: ,,Users'hellc'AppData'Local'Temp'_temp19536.msi
(T10256)Debug( 39): 05/21/20 23:35:03:332 versuchen Sie, die Datei zu Cüberprüfen: ''Users'hellc'AppData'Local'Temp''Local'Temp''Temp'Local'Temp',Temp'Local'Temp'Local'Temp'/Local'Temp':"05/21/20 23:35:03:332 Try file:'Users'hellc'AppData'Local'Local'Temp'Temp'/ _temp19536.msi
(T10256)Fehler( 165): 05/21/20 23:35:03:335 Die Datei C:'Users'hellc'AppData'Local'Temp'_temp19536.msi ist nicht signiert oder beschädigt
(T10256)Error( 634): 05/21/20 23:35:03:335 Datei wurde nicht von uns signiert, jetzt zurückgeben
(T10256)Debug( 39): 05/21/20 23:35:03:332 versuchen Sie, die Datei zu Cüberprüfen: ''Users'hellc'AppData'Local'Temp''Local'Temp''Temp'Local'Temp',Temp'Local'Temp'Local'Temp'/Local'Temp':"05/21/20 23:35:03:332 Try file:'Users'hellc'AppData'Local'Local'Temp'Temp'/ _temp19536.msi
(T10256)Fehler( 165): 05/21/20 23:35:03:335 Die Datei C:'Users'hellc'AppData'Local'Temp'_temp19536.msi ist nicht signiert oder beschädigt
(T10256)Error( 634): 05/21/20 23:35:03:335 Datei wurde nicht von uns signiert, jetzt zurückgeben
- Wir haben bestätigt, dass die md5-Prüfsummen zwischen der temporären Datei auf dem Computer des Benutzers und dem, was vom Palo Alto Networks Update-Server für die Versionen übertragen wird, übereinstimmen, aber beim Versuch, die Datei zu starten, hat es einen 404-Fehler aufgefüllt, wie unten gezeigt wie folgt:
- Wenn der Kunde versucht, den Download-Prozess manuell auszulösen, indem er zu https://<portal’s ip="" or="" fqdn="">/global-protect/getmsi.esp</portal’s> navigiert, bemerkten wir die URL, die auflöst, um es zu IP trennen, und baten den Kunden, das Portal nur mit der öffentlichen Adresse zu lösen, anstatt 2 separate Einträge für interne Benutzer und externe Benutzer zu IP haben.
- Beim Ändern, um nur mit dem externen (12.*) IP Adresse konnte die App problemlos aktualisiert werden GlobalProtect
Additional Information
- Weitere Informationen zur vollständigen Konfiguration und der Komponenten finden GlobalProtect Sie im folgenden Dokument: Admin GlobalProtect Guide