Serial number becomes “unknown” after changing the instance type of the PA-VM

Serial number becomes “unknown” after changing the instance type of the PA-VM

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Created On 10/19/20 10:18 AM - Last Modified 08/19/21 18:08 PM


Symptom


After changing the instance type of the PA-VM in the public cloud, the serial number might become "Unknown", which can be checked from the GUI and in CLI, as shown below:
  1. CLI: Run the command show system info | match serial
  2. GUI: Check the "General Information" on the Dashboard: 
User-added image


Environment


  • Platform: PA-VM in Public Cloud
  • PAN-OS / Plugin Version: Any
  • Deployment: Existing


Cause


  • The CPUID/UUID values are assigned by the host where the VM is residing. Therefore, when the instance type changes, the VM might be migrated to another host, which will cause the CPUID/UUID values to change as well.
  • The serial number on the support portal is tied to the CPUID and the UUID values on the firewalls. So if they got changed, the support portal will no longer be able to recognize the firewall, which will cause the serial number to become “unknown”. No licenses will appear under GUI: Device > Licenses   
  • When the firewall starts without a serial number, it means that the VM has no capacity license installed. This might cause the dataplane to remain down, which will subsequently result in all the interfaces being down.


Resolution


  1. Open a Support Case.
  2. The support team will edit CPUID and UUID on the backend server to match the new values on the PA-VM instance.
  3. Once the edit is completed and the CPUID/UUID matches the firewall, then, retrieve the licenses on the firewall using either the CLI or GUI, as explained below:
    • GUI: Navigate to GUI:Device > Licenses > License Management and click on "Retrieve license keys from license server".
    • CLI: Run the command request license fetch
  4. Once the firewall fetches the licenses, it will restart all the services automatically to match the system specifications of the applied capacity licenses (i.e. VM-100, VM-300, VM-500, ...etc.).


Additional Information


On occasions, the serial number can also become "Unknown" after rebooting the VM as explained in this Knowledge Document

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