Error de "Dominio inexistente" o respuesta de "No tal nombre" DNS al resolver nombres de dominio
37924
Created On 09/30/20 16:44 PM - Last Modified 04/26/21 17:06 PM
Symptom
- Al intentar resolver el nombre de dominio mediante los servidores externos DNS NOT (empujados por la GP puerta de enlace), el siguiente mensaje de error se ve en el CLI archivo .
- El paquete de respuesta "No se puede decir tal nombre" se recibe localmente en el adaptador virtual.
- Estas respuestas no son visibles si la captura se toma de la puerta de enlace.
Environment
- Global Protect ( GP ) Cliente App 4.0.3 y superior.
- Global Protect Portal configurado para resolver todos los FQDN mediante DNS servidores asignados por el túnel (solo Windows).
Cause
- Si la opción "Resolver "Todos" FQDNs mediante DNS servidores asignados por el túnel (solo Windows)" se establece en YES la cual se encuentra en la red > Global Protect > Portales > (nombre) > el agente >App tabulador, todas las DNS peticiones salen vía la interfaz del túnel al servidor/s que es empujado por el GP gateway.
- Esta DNS configuración insertada desde GP gateway se encuentra GUI en: Network > Global Protect > Gateways > (nombre) > Agent > Network Services.
- Todas DNS las solicitudes enrutadas a través del túnel que están destinadas a los DNS servidores que son NOT empujados por el gateway se responden localmente con NXDOMAIN (Dominio no existente o "No tal nombre").
Resolution
Solución 1:
- Utilice los DNS servidores que se insertan a través de GP Gateway.
- Vaya a GUI : Network > Global Protect > Gateways > (nombre) > Agent > Network Services
- Configurar el DNS
- Vaya a GUI : Network > Global Protect > Portals > (nombre) >App pestaña Agente >
- Establezca la opción "Resolver "Todos" FQDNs mediante DNS servidores asignados por el túnel (solo Windows)" en NO.