firewallAnwendungsfehler, wenn Jumbo-Frames aktiviert sind

firewallAnwendungsfehler, wenn Jumbo-Frames aktiviert sind

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Created On 08/31/20 22:01 PM - Last Modified 03/26/21 18:35 PM


Symptom


 
  • Sie werden feststellen, dass eine große Anzahl von Sitzungen in den * *-Zustand gehen wird, DISCARD wobei die Anwendung als unknown-tcp angezeigt wird.
  • Der Sitzungstracker für die Sitzung zeigt den Status "Appid Stop Lookup" an.
session QoS rule : N/A (class 4)
tracker stage firewall : appid stop lookup
end-reason : unknown
  • DP-Monitorprotokolle zeigen den Leistungsindikator appid_post_pkt_queued mit dem Wert 4300 an, der der Appid-Warteschlange mit aktivierten Jumbo-Frames zugewiesen ist.
2020-08-30 11:01:56 :appid_post_pkt_queued 4300 0
2020-08-30 11:11:56 :appid_post_pkt_queued 4300 0
2020-08-30 11:21:56 :appid_post_pkt_queued 4300 0
2020-08-30 11:31:56 :appid_post_pkt_queued 4300 0
2020-08-30 11:41:56 :appid_post_pkt_queued 4300 0


Environment


  • PanOS 9.0.9-h1
  • PA-5220
  • Jumbo-Rahmen aktiviert


Cause


  • Durch aktivierendes Aktivieren von Jumboframes auf einem firewall wird die Größe der Appid-Warteschlange von 65536 auf 4096 reduziert.
  • Der unbekannte TCP-Datenverkehr in der Umgebung eines Kunden führt dazu, dass die AppID-Warteschlange schnell aufgefüllt wird
  • Sobald das Limit für die Appid-Warteschlange erreicht wurde, wird die Standardaktion drop.


Resolution


Upgrade auf PanOS Version 9.0.10

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