Prisma Cloud Compute : l’état des magasins de secrets affiche une erreur pour un secret qui a déjà été supprimé

Prisma Cloud Compute : l’état des magasins de secrets affiche une erreur pour un secret qui a déjà été supprimé

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Created On 04/30/24 20:12 PM - Last Modified 05/07/24 13:55 PM


Symptom


  • La page État sous Gérer l’authentification > > secrets affiche l’état « Échec » en raison d’un secret qu’il tente de synchroniser, mais qui a déjà été supprimé.
Error-Secret.png
  • L’ajout d’un nouveau secret se déroule normalement et n’est pas affecté par l’erreur.
 
 
 


Environment


  • Prisma Cloud Compute auto-hébergé
  • Prisma Cloud Compute Enterprise Edition (SaaS)
 
 
 


Cause


Lorsque des règles d’accès sont créées, l’état des secrets est régulièrement actualisé pour s’assurer que tout est à jour. Si un secret a été supprimé ou n’est plus accessible, l’état de la console continue d’afficher l’état d’erreur jusqu’à ce que la règle soit mise à jour ou qu’une nouvelle règle soit créée.

 


Resolution


  1. Sous Défendre > accès > secrets, mettez à jour la règle d’accès qui utilisait le secret supprimé/inaccessible pour utiliser une version mise à jour.
  2. S’il n’existe actuellement aucune règle d’accès, créez-en une et spécifiez le secret nouvellement ajouté (ou le secret mis à jour).
  3. Une fois la règle en place, les erreurs relatives au secret supprimé/inaccessible seront effacées.
Capture d’écran 2024-04-30 à 3.12.08 PM.png
 
 
 
 


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