Prisma Cloud Compute: Secrets stores status is showing an error for a secret that has already been deleted

Prisma Cloud Compute: Secrets stores status is showing an error for a secret that has already been deleted

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Created On 04/30/24 20:12 PM - Last Modified 04/30/24 20:21 PM


Symptom


  • The Status page under Manage > Authentication > Secrets shows a "Failed" status due to a secret that it is trying to sync but has already been deleted.
Error-Secret.png
  • Adding a new secret will proceed as normal, and is not affected by the error.
 
 
 


Environment


  • Prisma Cloud Compute Self-Hosted
  • Prisma Cloud Compute Enterprise Edition (SaaS)
 
 
 


Cause


When Access rules are created, secrets status are routinely refreshed to ensure everything is up to date. If a secret has been deleted or is no longer accessible, the console status will continue to show the error state until the rule is updated or a new rule is created.

 


Resolution


  1. Under Defend > Access > Secrets, update the access rule that was utilizing the deleted/inaccessible secret to use an updated version.
  2. If no access rules currently exist, create one and specify the newly added secret (or updated secret).
  3. Once the rule is in place, the errors pertaining to the deleted/inaccessible secret will be cleared out.
Screenshot 2024-04-30 at 3.12.08 PM.png
 
 
 
 


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