SaaS Security API notifies and reports admins when a “Saas service is unavailable”

SaaS Security API notifies and reports admins when a “Saas service is unavailable”

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Created On 07/19/22 01:57 AM - Last Modified 11/15/25 00:26 AM


Symptom


When services are running normal, SaaS Security API reports Service Performance Status as shown in the picture
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When one or more services unavailable, SaaS API reports Service Performance Status in Down or Degraded state

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An email notifications to admins will be sent, if the admin/user was added to Add Recipient to Alerts to alert the users in real time 

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Environment


A SaaS Security API accessible via URL or HUB(apps.paloaltonetworks.com)

On SaaS Security API, navigate to SETTINGS->Cloud Apps & Scan Settings page where the Service Performance Status is reported for various cloud services that the SaaS Security API relies on.

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SaaS Security API provides ability to add users or admins to receive Alert Notifications in real time when the status of a service change.
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Situation like “a complete widespread outage” of services/instances hosted in various Geo, Palo Alto notifies users with an advisory note on “status.paloaltonetworks.com". Users subscribe to receive critical alerts in real time. This example shows operational status for instances hosted on various Geo/regions 
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Cause


Although the surface level reporting or email notifications are showing service in Degraded or Down or Service is Unavailable, fundamental issues could be due to various reasons. A few examples include and not limited to:
-Connectivity issues to DLP or Wildfire Services or server(hosted internally or in cloud).
-Issues with the servers, services or the instances hosted on the cloud
-Connections to cloud app or cloud app instance may be failing which is a result of infrastructure issues
-Core issues: Infrastructure issues related to tenant instance, app instances which are hosted on AWS

  • Issues with the instances which are hosted in cloud
  • Core services may be down due to infrastructure maintenance (on AWS)


Resolution


Service restoration or incident recovery, could vary depending on the customer issue situation:
-Often times, reporting of status get cleared after a task is completed and will show normal status.
-Review any advisory note on “status.paloaltonetworks.com" for critical incidents and service restoration.
-For persistent and recurring issues, contact Palo Alto technical support to get the issues resolved.


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