Can't upgrade PA-VM from PAN-OS 9.1 to PAN-OS 10.x due to hard disk issue
13279
Created On 07/15/22 16:12 PM - Last Modified 01/17/24 03:55 AM
Symptom
- Can't upgrade from PAN-OS 9.1 to PAN-OS 10.x due to hard disk issue.
- Flagging on minimum hard disk size being 60GB and virtual disk size was already increased to 60 GB.
Environment
- PA-VM series
- VMware ESXi platform
Cause
PAN-OS partition does not get expanded when virtual disk size is increased from hypervisor
Resolution
- Run "show system disk-space" command to verify the current disk
- Shut down the PA-VM and add the new disk under Edit Setting on vSphere Client Console
- Execute CLI command from VM to clone the OS image to new disk (i.e., sdb) -
> request system clone-system-disk target <name of new disk>
- clone-system-disk command will trigger a restart and upon successful conversion you will receive the disk cloning procedure completed message in console
- Shut down the PA-VM to change the LUN ID. Remove the SCSI (0:0) allocation from Hard disk 1 (old) And move Hard disk 2 (new) to first.
- Start the PA-VM to verify the normal operation and CLI.
- To verify partition increase, run this command.
> show system disk-space
Additional Information
- As for the public cloud environment involving AWS and Azure, the disk upgrade may not be supported, in which upgraded disk will not be reflected under PAN-OS disk-partition (show system disk-space). Deployment of new PA-VM defaulting to 60 GB disk may be required.
- The disk size added in above Step 2. must be strictly 60GB.
- Once the system disk usage was expanded to 60GB by executing "request system clone-system-disk" CLI command, or the PA-VM instance is initially deployed with 60GB system disk, it is no longer required to run the above steps.