Firewall not sending logs to log collector and connection status is inactive

Firewall not sending logs to log collector and connection status is inactive

35551
Created On 06/27/22 17:20 PM - Last Modified 03/22/23 20:12 PM


Symptom


  • Firewall not sending logs to log collector
  • The connection status shows Inactive on firewall
  • All other status related to DNS, Registration, SSL and TCP are success.
 
>request log-collector-forwarding status
Log Collector : xxxxxxxxx
Conn ID : lr-xx.xx.xx.xx
Connection IP : xx.xx.xx.xx
Conn Source IP : lr - def
High speed mode : Disabled
Connection Status : lr - Inactive
DNS :
msg : Successfully resolved FQDN for connid (lr-xx.xx.xx.xx-def), IP (xx.xx.xx.xx)
status : success
timestamp : 2022/06/16 06:03:49

Registration :
msg : Re-sending lcs-register for lc_conn_id:lr-xx.xx.xx.xx-def
status : success
timestamp : 2022/06/16 06:33:52

SSL :
msg : ssl channel established
status : success
timestamp : 2022/06/16 06:03:51

TCP :
msg : tcp connection established
status : success
timestamp : 2022/06/16 06:03:49

Conn Uptime : 0
Re-conn Count : 0

Rate : 0 logs/sec



 


Environment


  • Palo Alto Firewalls
  • PAN-OS: 9.1, 10.0, 10.1, 10.2
  • Panorama Log Collector


Cause


  1. Issue occurs when log collector and log forwarding device version combination not supported by log collector.
  2. Log collector configd logs (less mp-log configd.log) display this this information status.
Sample: Log collector is running on 9.1.4 and Firewall is running on 10.1.5-h1 due to that configd logs showing version combination not supported. 
2022-06-26 21:26:45.249 +0100 Version combination not supported: device: xxxxx, server: 9.1.4, client: 10.1.5-h1

 


Resolution


Upgrade the log collector to same version as device version.

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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000CqDHCA0&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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