Unique Assets in Prisma Cloud Asset Inventory tab giving Error "Something went wrong" after adding large number of Account Groups in the Filter

Unique Assets in Prisma Cloud Asset Inventory tab giving Error "Something went wrong" after adding large number of Account Groups in the Filter

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Created On 06/06/22 03:50 AM - Last Modified 06/06/22 03:56 AM


Symptom


  • Unique Assets in Prisma Cloud Asset Inventory tab giving Error "Something went wrong" after adding large number of Account Groups in the Filter
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  • At times, the count of Unique Assets is decreasing while adding more Account Groups in the Filter.


Environment


  • Prisma Cloud


Cause


  • Asset Inventory filters work with a GET API call as Console UI makes a GET API call to fetch the Asset Counts.

Screenshot 2022-06-06 at 11.27.41 AM.png
 
  • However, when a large number of Account Groups are selected in the Filter, there is a possibility that it may cross the allowed limit for a Request URL causing the API call to fail with the Error message "Something went wrong".
  • Sometimes, this API call failure may also result in incorrect or decreasing value of Unique Assets.


Resolution


  • There is an existing road map to move this functionality to a POST API call as done in other Prisma Cloud sections with no ETA at this time.
  • Meanwhile, as an immediate workaround, you can leverage a POST endpoint available to get the same data using an API client like Postman.
  • For more information, refer : Asset Inventory View V2 - POST


 


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