Registerkarte "Eindeutige Assets im Asset-Inventar" mit dem Fehler "Etwas ist schief gelaufen", nachdem eine große Anzahl von Kontogruppen im Prisma Cloud Filter hinzugefügt wurde
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Created On 06/06/22 03:50 AM - Last Modified 03/02/23 01:54 AM
Symptom
- Registerkarte "Eindeutige Assets im Asset-Inventar" mit dem Fehler "Etwas ist schief gelaufen", nachdem eine große Anzahl von Kontogruppen im Prisma Cloud Filter hinzugefügt wurde
- Manchmal nimmt die Anzahl der eindeutigen Assets ab, während weitere Kontogruppen im Filter hinzugefügt werden.
Environment
- Prisma Cloud
Cause
- Asset-Inventarfilter funktionieren mit einem GET API Anruf, während die Konsole einen GET API Anruf tätigt, um die UI Asset-Anzahl abzurufen.
- Wenn jedoch eine große Anzahl von Kontogruppen im Filter ausgewählt wird, besteht die Möglichkeit, dass der zulässige Grenzwert für eine Anforderung URL überschritten wird, wodurch der Anruf mit der API Fehlermeldung "Etwas ist schief gelaufen" fehlschlägt.
- Manchmal kann dieser API Anruffehler auch zu einem falschen oder abnehmenden Wert von Unique Assets führen.
Resolution
- Es gibt eine vorhandene Roadmap, um diese Funktionalität in einen POST API Aufruf zu verschieben, wie dies in anderen Prisma Cloud Abschnitten ohne ETA zu diesem Zeitpunkt der Fall ist.
- In der Zwischenzeit können Sie als sofortige Problemumgehung einen POST verfügbaren Endpunkt nutzen, um dieselben Daten mit einem API Client wie Postman zu erhalten.
- Weitere Informationen finden Sie unter: Asset Inventory View V2 - POST