GlobalProtect クライアントが「不明なサーバー証明書エラー」というエラーで接続に失敗します。 エラー128」
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Created On 06/01/22 02:29 AM - Last Modified 05/15/23 09:14 AM
Symptom
- のGlobalProtectクライアントは、以下のように「不明なサーバー証明書エラー」によりポータルまたはゲートウェイへの接続に失敗します。
- クライアント証明書認証が必要な構成に応じて、ポータル/ゲートウェイまたはその両方でエラーが発生する可能性があります。
Environment
- パロアルト ストラータ Firewall
- サポートされています PAN-OS
- GlobalProtect Windows での認証にクライアント証明書を使用するクライアントOS。
- Prisma Access ために Mobile Users
Cause
- これは、GlobalProtectクライアントは、必要なクライアント証明書の秘密キーにアクセスします。TLS認証。
- これは、Windows またはオペレーティング システム上の破損した証明書の問題である可能性があります(OS ) レベルの問題では、証明書に秘密キーが含まれている場合でも、証明書の秘密キーにアクセスできません。
- これは、次の方法でさらに検証できます。 PanGPA ログ。
(P15248-T15144)Error(2329): 05/27/22 20:21:37:378 error = ERROR_WINHTTP_CLIENT_CERT_NO_ACCESS_PRIVATE_KEY (P15248-T15144)Debug(2416): 05/27/22 20:21:37:378 winhttpObj, got ERROR_WINHTTP_CLIENT_CERT_NO_ACCESS_PRIVATE_KEY, clean cert cache now (P15248-T15060)Debug( 408): 05/27/22 20:21:37:599 Receive gps message with type portal-certificate-verification. //Truncated for Brevity <portal-config-version>4100</portal-config-version> <error-must-show/> <error-must-show-level>error</error-must-show-level> <portal-status>Invalid portal</portal-status> <user-name>user.lastname</user-name> <username-type>sso</username-type> <state>Disconnected</state> <check-version>no</check-version> <portal>customer.gpcloudservice.com</portal> <discover-ready>no</discover-ready> <mdm-is-enabled>no</mdm-is-enabled> <error-code>128</error-code>
Resolution
- クライアント証明書を再インストールするユーザーのマシン上で。
- 再度接続すると、今度は認証が完了するはずです。
Additional Information
- 同じクライアント マシンで問題を再現するには、ポータルまたはゲートウェイにアクセスします。URL Internet Explorer または Edge ブラウザ経由 (プライベートモードで) これもこのエラーにより失敗します。
- 証明書を再インストールしても問題が解決しない場合は、証明書をアップグレードしてください。OS最新のパッチまで。
- クライアント証明書に完全な証明書チェーンがあり、適切なフォルダー ([個人] > [証明書]) にインストールされていることを確認します。
- お客様に追加の作業を依頼してくださいOSレベルのトラブルシューティングを行って、その理由を見つけます。Globalprotectクライアントは証明書の秘密キーにアクセスできません。