Prisma Cloud Authentication Failed with "We were unable to successfully authenticate you with your SSO Identity Provider." while configuring SSO
9471
Created On 05/27/22 02:26 AM - Last Modified 10/26/25 22:14 PM
Symptom
An error occurs "We were unable to successfully authenticate you with your SSO Identity Provider." while configuring SSO (Single Sign-On) in Prisma Cloud.
Environment
Configuring Prisma Cloud with SSO (Single Sign-On)
Identity Provider Initiated (IdP-initiated)
Cause
Prisma Cloud SSO is case-sensitive. This error occurs because Identity Provider (IDP) Role name does not match with Prisma Cloud Role name.
Example:
Role name: system admin in IDP
Role name: System Admin in Prisma Cloud
Resolution
Ensure Identity Provider (IDP) Role name match with Prisma Cloud Role name.
Example:
IDP Role name: System Admin
Prisma Cloud Role name: System Admin
Create Role in Prisma Cloud:
- Login to Prisma Cloud
- Go to Settings (gear icon) > Access Control > Roles > Add >Roles
- Type System Admin in Name field.
- Submit