Prisma Cloud Authentication Failed with "We were unable to successfully authenticate you with your SSO Identity Provider." while configuring SSO

Prisma Cloud Authentication Failed with "We were unable to successfully authenticate you with your SSO Identity Provider." while configuring SSO

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Created On 05/27/22 02:26 AM - Last Modified 10/26/25 22:14 PM


Symptom


An error occurs "We were unable to successfully authenticate you with your SSO Identity Provider." while configuring SSO (Single Sign-On) in Prisma Cloud.

Screen Shot 2022-05-26 at 9.35.24 PM.png
 


Environment


Configuring Prisma Cloud with SSO (Single Sign-On)
Identity Provider Initiated (IdP-initiated) 


Cause


Prisma Cloud SSO is case-sensitive. This error occurs because Identity Provider (IDP) Role name does not match with Prisma Cloud Role name.

Example:
Role name: system admin in IDP
Role name: System Admin in Prisma Cloud

 



Resolution


Ensure Identity Provider (IDP) Role name match with Prisma Cloud Role name.

Example:
IDP Role name: System Admin
Prisma Cloud Role name: System Admin

 

Create Role in Prisma Cloud:

  1. Login to Prisma Cloud
  2. Go to Settings (gear icon) > Access Control > Roles > Add >Roles
  3. Type System Admin in Name field.
  4. Submit
Screen Shot 2022-05-31 at 11.30.27 AM.png
 

 



Additional Information


Set up SSO Integration on Prisma Cloud



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