WAAS Melden des Fehlers "Fehlgeschlagene Sendeanforderung: Kontext abgebrochen" in WAAS Connectivity Monitor und Prisma Cloud Defender Logs
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Created On 05/13/22 07:50 AM - Last Modified 03/02/23 02:24 AM
Symptom
- Client-zu-Server-Kommunikation schlägt fehl, da WAAS das Modul nach einem Fehler in Connectivity Monitor und Prisma Cloud Defender Logs einen Fehler meldetWAAS.
DEBU 2022-04-28T12:12:08.450 2022-04-28T11:31:13.957 failed sending request: Post http://localhost:8081/xxxx/xxxx/search_order.jsp: context canceled, route: "10.10.xx.xx:8081/xxxxx/xxx/search_order.jsp", request inspection duration: "0 ms", total serve duration: "84148 ms"
- Häufigstes Netzwerkszenario: Client- > Internet> > WAAS Web-/Anwendungsserver
Environment
- Prisma Cloud Compute Saas
- Prisma Cloud Compute Self-gehostete Version 21.04 und höher
Cause
- "Kontext abgebrochen" weist häufig auf Netzwerkverbindungsprobleme zwischen dem Defender und dem Anwendungsserver hin.
- Dies kann auch aufgrund von Inkonsistenzen mit verschiedenen Proxy-Umgebungen (z. Szenario: Internet>Reverseproxy > > WAAS Webserver).
- Dies kann auch bedeuten, dass das Limit für das Lesetimeout (sec) für das jeweilige WAAS Policy.
Resolution
- Überprüfen Sie die Anwendungsserverprotokolle während der Ausgabe auf anwendungsspezifische Fehler (z. B. kann beobachtet werden, ESOCKETTIMEDOUT wenn ein Webserver den Header "Accept-Encoding" im HTTP Request-Header nicht finden konnte).
- Überprüfen Sie die Konfiguration für "Lesetimeout (sec)": Compute > Defend > WAAS > > Rule > Actions > Edit > WAAS policyWAAS Erweiterte Proxyeinstellungen
NOTE: Dies kann auch als Proxy-Timeout bezeichnet werden, das die maximale Dauer in Sekunden für das Lesen der gesamten Anforderung, einschließlich des Textes, angibt. A 500 Fehlerantwort wird zurückgegeben, wenn eine Anforderung nicht innerhalb des Timeoutzeitraums gelesen wird. Für Anwendungen, die mit großen Dateien arbeiten, ist eine Anpassung des Proxy-Timeouts erforderlich.