Auto-Remediation needs to be enabled to select auto remediable policies in Prisma Cloud

Auto-Remediation needs to be enabled to select auto remediable policies in Prisma Cloud

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Created On 05/08/22 20:21 PM - Last Modified 02/06/25 22:29 PM


Symptom


Prisma Cloud Does not provide Auto Remediated policies if you do not enable Auto-Remediation when setting up an Alert Rule.

Screen Shot 2022-05-08 at 12.21.41 PM.png
 


Environment


  • Prisma Cloud
  • Alert Rule


Cause


When setting up an alert rule with Auto Remediation. You must enable Auto-Remediation.
When enabled, all applicable alerts will be auto remediated irrespective of when they were created.


Resolution


  1. Navigate to Alert rules on Prisma. Enable Auto-remediation (optional). 
Alerts > Add Alert Rules > Add Details
Screen Shot 2022-05-08 at 12.21.41 PM.png
  1. Assign your Targets (Account Groups)
Alerts > Add Alert Rules > Add Details > Assign Targets
Screen Shot 2022-05-08 at 12.23.38 PM.png
  1. Policies with Auto-Remediation will display when assigning policies to your alert rule.
Alerts > Add Alert Rules > Add Details > Assign Targets > Assign PoliciesScreen Shot 2022-05-08 at 12.29.06 PM.png 

 


Additional Information


Please take note that there will be a difference in the amount of policies displayed when you enable Auto-Remediation 

Screen Shot 2022-06-01 at 4.36.12 PM.png

Screen Shot 2022-06-01 at 4.38.01 PM.png

For more information on creating an Alert Rule. Please see our documentation here.


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