Local admin usernames pushed from Panorama locked due to expired password

Local admin usernames pushed from Panorama locked due to expired password

1978
Created On 03/13/24 04:55 AM - Last Modified 05/29/24 03:12 AM


Symptom


  • Local usernames pushed from Panorama is locked and showing "Change expired password for user: xxxx".
  • When the customer is using the username to log into firewall GUI, it shows invalid username and password.
image.png


Environment


  • Panorama managed Firewalls
  • Supported PAN-OS
  • Templates


Cause


  • Local username was pushed to firewall but used since it's pushed.
  • The password expiry period causes the password to expire
  • Authd.log (less mp-log authd.log) display the following logs when logging into GUI:
+1100 debug: pan_auth_check_password_expiry_and_authenticate(pan_auth_state_engine.c:1310): user "XXXX": last password change time = Thu Sep 21 15:00:22 xxxx
, so elapsed_days = 173, while expiry period = 60 
+1100 debug: _lock_unlock_user(pan_auth_state_engine.c:374): lock_user = 1; is_exp_admin = 0 --> password_expiry_locked = TRUE


Resolution


  1. Configure the same password for the admin usernames in the related template.
  2. Commit the change (no real change) to the Panorama.
  3. Push the template to the associated firewalls.
  4. This will update the status of the username to unlocked and the customer can use it to log into the GUI.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000008XXrCAM&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail