When using Strata Cloud Manager for SaaS Security the "Assign To" field in Policy is not populating users from Common Services of IAM
680
Created On 03/01/24 23:12 PM - Last Modified 10/18/24 02:57 AM
Symptom
- All admin users populated within HUB >Common Services >Identity & Access Management.
- “Assigned To” field gets user data from the Data Security Database which maintains user collection from the entries imported from HUB >Common Services >Identity & Access Management.
- For a policy (new or existing) when admin click on “Assign To” field, the users full name is not populated causing inability to assign to an owner of a ticket.
Environment
- Strata Cloud Manager (SCM)
- Data Security or CASB
Cause
- Under HUB->Common Services->Identity Access & Management->”Display Name” contains information other than First and Last Name (example email).
- This can happen as Data Security field gets user name for “Assign To” from IAM users.
- The display name should be limited to first and last name.
Resolution
Confirm the following criteria are met before using “Assign To” field within a policy
- Ensure all the admins in HUB >Common Services >Identity & Access Management are created or situated with a Display name being “First Last” and Identity being “Email address”.
- Ensure that all admins have logged in to SCM >SaaS Security >Data Security have accepted EULA terms and conditions once.